Invalid command after install of Virtualmin

Hello Everyone,

    I installed Webmin v1.570 on an Ubuntu 11.10 Server install, I am getting an error after the install when I go to Webmin -> Servers -> Virtualmin Virtual Servers -> Re-Check and Refresh Configuration and i get the following error:

Apache configuration errors were found :

Syntax error on line 18 of /etc/apache2/conf.d/install.sh:
Invalid command 'prosupported="', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.

… your system is not ready for use by Virtualmin.

My log located here -> /root/virtualmin-install.log shows the following:

INFO - 2011-12-22 18:41:24 - Started installation log in /root/virtualmin-install.log
DEBUG - 2011-12-22 18:41:24 - Install mode: full
DEBUG - 2011-12-22 18:41:24 - Product: Virtualmin GPL
DEBUG - 2011-12-22 18:41:24 - Virtualmin Meta-Package list: virtualmin-base
DEBUG - 2011-12-22 18:41:24 - install.sh version: 1.0.6
INFO - 2011-12-22 18:41:24 - Checking for fully qualified hostname…
INFO - 2011-12-22 18:41:24 - Hostname OK: fully qualified as ubuntu1.coopfire.com
INFO - 2011-12-22 18:41:24 - Installing serial number and license key into /etc/virtualmin-license
INFO - 2011-12-22 18:41:25 - Loading OS selection library…
INFO - 2011-12-22 18:41:26 - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - 2011-12-22 18:41:26 - Loading OS list…
INFO - 2011-12-22 18:41:26 - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.
INFO - 2011-12-22 18:43:22 - Started installation log in /root/virtualmin-install.log
DEBUG - 2011-12-22 18:43:22 - Install mode: full
DEBUG - 2011-12-22 18:43:22 - Product: Virtualmin GPL
DEBUG - 2011-12-22 18:43:22 - Virtualmin Meta-Package list: virtualmin-base
DEBUG - 2011-12-22 18:43:22 - install.sh version: 1.0.6
INFO - 2011-12-22 18:43:22 - Checking for fully qualified hostname…
INFO - 2011-12-22 18:43:22 - Hostname OK: fully qualified as ubuntu1.coopfire.com
INFO - 2011-12-22 18:43:22 - Installing serial number and license key into /etc/virtualmin-license
INFO - 2011-12-22 18:43:22 - Loading OS selection library…
INFO - 2011-12-22 18:43:23 - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - 2011-12-22 18:43:23 - Loading OS list…
INFO - 2011-12-22 18:43:24 - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.

and the install.sh is located at this path: /etc/apache2/conf.d/install.sh and shows this:

Currently supported systems:

prosupported=" Fedora Core 10-11 on i386 and x86_64
CentOS and RHEL 3-6 on i386 and x86_64
Scientific Linux 6 on i386 and x86_64
Debian 4.0, 5.0, and 6.0 on i386 and amd64
Ubuntu 8.04 LTS and 10.04 LTS on i386 and amd64
FreeBSD 7.0 and 7.1 on i386 and amd64"
gplsupported=" CentOS 4-6 on i386 and x86_64
RHEL 5 and 6 on i386 and x86_64
Scientific Linux 6 on i386 and x86_64
Debian 4.0, 5.0 and 6.0 on i386 and amd64
Ubuntu 8.04 LTS and 10.04 LTS on i386 and amd64"

log=/root/virtualmin-install.log
skipyesno=0

I have no clue where to start looking and how to troubleshoot.

Thank you in advance.

Hmm, did you by chance download the Virtualmin install.sh script into Apache’s /etc/apache2/conf.d directory? There shouldn’t be an install.sh script in there, but that’s what Apache is complaining about.

Note though that Ubuntu 11.10 isn’t one of the supported distros – Virtualmin only supports Ubuntu’s LTS releases – so 10.04 is the most recent supported version.

You can see a list of supported distros here:

http://www.virtualmin.com/os-support.html