Installing webmin & mariadb on rocky linux

hello -

something appeared to go wrong with my virtualmin/webmin install in regards to MariaDB.

i was receiving this message:

Problem: package MariaDB-server-xxx requires MariaDB-client, but none of the providers can be installed

the dnf message also referenced:


running these manually did not resolve anything. and the server configuration was complaining about the missing " /etc/rc.d/init.d/mysqld" file.

however, i was able to indeed install Mariadb 10.5 using dnf no problem.

to resolve, i went into the MariaDB Database Server configuration and changed:

OLD: Command to start MySQL server: /etc/rc.d/init.d/mysqld start
NEW: Command to start MySQL server: systemctl start mariadb.service
OLD: Command to start MySQL server: /etc/rc.d/init.d/mysqld stop
NEW: Command to start MySQL server: systemctl stop mariadb.service

i have never needed to do this before, but maybe it’s just because RockyLinux is still in its infancy.

and /virtual-server/check.cgi?&undefined=&xnavigation=1 now appears to be satisfied.


Rocky-Linux 8.4
Linux 4.18.0-305.7.1.el8_4.x86_64 #1 SMP Tue Jun 29 19:22:12 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Where did that package come from? It’s not from the OS repo, right?

You can’t enable third-party repos until after Virtualmin is installed. And, even then, you probably should not.

The service changes are probably resolved by newer Webmin versions. (Or, will be once we spend a little time with it.)

Where did that package come from? It’s not from the OS repo, right?

sorry but i am not really sure - i just started out with a new RockyLinux and now i always install Virtualmin the very FIRST, and let the virtuamin/webmin installation procedure take care of PHP & MariaDB.

i will try again on a VirtualBox RL & see if i get the same results.

On CentOS, the package names are of the form mariadb-server.... No CamelCase. If Rocky has changed the package names, that’s an annoying thing, and surely a bug. I assume you actually have the repos enabled or some other repo providing those packages.

hey Joe - i am sorry you are working on the weekend…

i had the same issue when installing RockyLinux on VirtualBox.

notice this error:

going into the Mysql config and changing the “Command to start MySQL server” and the “Command to stop MySQL server” would appear to fix the issue.

this issue seems very minor, but i thought it worth mentioning. hopefully this does not ruin anybody’s weekend.

That’s not the issue I’m concerned about (though you need to be, since it means many services are pointing to the wrong start/stop scripts). That means Webmin detected the OS wrong; I suspect a newer Webmin will detect it correctly, since Jamie and Ilia have done some work on this.

You shouldn’t consider this system production ready. If Webmin misdetected the OS and is treating it like a “generic Linux” system (which I’m pretty confident it did), you’ll have many minor config quirks like this all over the place.

Edit: Also note that just installing a newer Webmin might not fix it, either. I don’t know if it does a wholesale config change after initial installation, since an entire OS switch is not a normal use case. I’m not actually sure what Webmin does when it switches from generic Linux profile to a properly defined one…

well THATS not good news…

here is how i installed:

curl \
        | sed -e 's/^vm_version=7$/vm_version=6/' > ;

chmod 700 ; ## change protections

./ ; ## run script

can you think of anything i should do differently?

I guess just wait until we have a Webmin in the repo that recognizes Rocky. Or preinstall the newest Webmin version before installing Virtualmin (normally I wouldn’t tell anyone to do this, but if you’re really fired up to use Rocky, it will probably do it)…and check to be sure it got all your configs right before installing Virtualmin.

Right now, Rocky is not supported by the Virtualmin installer, so I’m still recommending folks install on CentOS 8 with plans to switch when it’s necessary. I have not had time to do anything with the installer for Rocky.

ouch… well OK, here is what i am going to do: (unless you think otherwise)

dnf --assumeyes install perl perl-Net-SSLeay openssl perl-IO-Tty perl-Encode-Detect ;
dnf --assumeyes install wget ;
cat > /etc/yum.repos.d/webmin.repo <<END_OF_REPO;
name=Webmin Distribution Neutral

wget ;
rpm --import jcameron-key.asc ;
dnf --assumeyes install webmin ;

/etc/webmin/stop ; # this might not do anything?
kill -9 $(pgrep miniserv;) ; ## ??? this seems to still be required…?

systemctl enable webmin.service;
systemctl stop webmin.service;
systemctl start webmin.service;
systemctl status --no-pager --full webmin.service;

then run this if the Mariadb checks out:

| sed -e ‘s/^vm_version=7$/vm_version=6/’ > ;

chmod 700 ; ## change protections

./ ; ## run script

I wouldn’t enable the Webmin repo. Just install the RPM using the rpm command. New Webmins will make it to Virtualmin repo soon.

That makes it just one step instead of like 20.

joe - what do you think?

## How To Install an RPM File on Linux (CentOS/RHEL & Fedora)

dnf --assumeyes install wget ;

wget ;

dnf localinstall webmin-1.979-1.noarch.rpm ; ## (had to run twice)

## check webmin install
systemctl stop firewalld.service ;

and by the way, as always, THANK YOU for your help and your work with Virtualmin/Webmin.

It’s probably good. As long as the MySQL module is trying to use service commands to stop and start, you’re good (or as good as it can be, given that I haven’t done any testing myself).

joe -

this is extremely minor, but hopefully this will make your own future work a little easier. i received the following error during the virtualmin install after installing webmin from RPM as suggested:

▣▣▣ Phase 3 of 3: Configuration
ERROR: can’t load appenderclass ‘Log::Log4perl::Appender::File’
Can’t locate File/ in @INC (you may need to install the File::Path module) (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/share/perl5/vendor_perl/Log/Log4perl/Appender/ line 11.
BEGIN failed–compilation aborted at /usr/share/perl5/vendor_perl/Log/Log4perl/Appender/ line 11.
Compilation failed in require at (eval 10) line 1.
▣▣▣ Cleaning up

so i ran my own personal “perl installer” and the Virtualmin problem went away. my perl installer for the most part just gets CPAN ready to go.

and i cannot stress this enough, Joe: THANK YOU for everything. And please know that your work is making life easier for the rest of us. Indeed, i hope this does not sound like a cliche, but your efforts really are making the world a better place.


dnf --assumeyes localinstall webmin-1.979-1.noarch.rpm ;
## (this fails the first time unless CPAN is properly installed and will be successful the second without CPAN)

1 Like

Just an FYI - that the script migrate at rocky-tools/migrate2rocky at main · rocky-linux/rocky-tools · GitHub worked. At least on my test CentOS8 system. Virtualmin even recognized the new OS, etc. There was a manual update of one of the respositories that was needed, but that was it.

Just my 3 cents (inflation) - Unless you are a real server admin that understands command line :: for prod servers where you want to use Virtualmin, just use CentOS8 for now, you can migrate later. Or, backup and run the migrate script if you absolutely want to move to Rocky.

remember that the deadline is the end of the year. IMHO the more slack-time you can build into a migration, the better.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.