Installing Virtualmin on AWS new Graviton2 t4g based on 64-bit ARM

OS: CentOS 8 arm64
Host: t4g.small - 2GB RAM - 2 vCPU

I’ve tried to install virtualmin on the new AWS t4g.small EC2 but it failed, The OS must be arm64 so I installed the AWS CentOS 8 (arm64) from AWS marketplace and when try installing Virtualmin…

  1. Virtualmin shown the low memory message and suggest the swap file.
  2. It completely failed after the swap file step.
  3. I saw it tried to download aarch64 file (Figure 2) but the line after is ERROR 404.

I saw an article form 2015 about arm64 processor, So I supposed that the virtualmin is now compatible with arm64, or not?


Check this link.

The list of supported distros and architectures is right there in your first screenshot! And on the list of grade A supported operating systems. Not sure how to make it more clear.

When we have more paying customers asking for it, we’ll be able to devote resources to developing and maintaining for ARM. We just don’t have the resources for it, currently.


This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.