Installing Virtualmin (gpl) on Debian Lenny 64bit

Running Debian Lenny (x64) on my server, and I’m at a loss here. When I run the script, it gets almost all the way through and then it spits out this message:

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem: subprocess post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of postgresql: postgresql depends on postgresql-8.3; however: Package postgresql-8.3 is not configured yet. dpkg: error processing postgresql (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of virtualmin-base: virtualmin-base depends on postgresql; however: Package postgresql is not configured yet. dpkg: error processing virtualmin-base (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: postgresql-8.3 postgresql virtualmin-base

FATAL - Fatal Error Occurred: Installation failed: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

It looks like it’s hanging up on postgresql with dependency problems, and I don’t know what I have to do to make it install the rest of the way. Are there extra sources I need to put in sources.lst to make postgresql install properly?

I’ve searched through these forums as best I can and googled it in general, but I haven’t found anything that I understand in the way of fixing the problem. Here’s hoping someone sees this and knows the way to fix it.

I’m not entirely sure how. But here’s what I did.

When I ran the script I got the error message above. Then I purged the offending packages:

apt-get purge postgresql-8.3

(purging that file also removed postgresql and virtualmin-base.)

Then I installed postgresql:

apt-get install postgresql

Which worked.

Then I ran the script again, and virtualmin installed without any problems whatsoever.

Why? Dunno. Stupid computer.

apt-get cannot be convinced to replace packages without human intervention, via any means I’ve been able to find (we already enable every possible option for non-interactive use…it just doesn’t work for replacing packages). So, basically, if you don’t have a freshly installed OS on a Debian or Ubuntu system, you might run into packages that cannot be installed because a conflicting package is already installed.

So, start fresh with a basic OS install…don’t install anything before installing Virtualmin, and all will be well.