Installing Virtualmin fails

Seems to be the same issue as here: , except for the “Maybe fixed?” part

Installing PHP7: Success.
Spin pid is: 11824
Marking 'Virtualmin LAMP Stack' for install: Success.
Spin pid is: 11915
Marking 'Virtualmin Core' for install: Success.
Spin pid is: 12006
Maybe run: yum groups mark install (see man yum)
Installing dependencies and system packages: Success.
Spin pid is: 12109
Warning: group Virtualmin Core does not exist.
Maybe run: yum groups mark install (see man yum)
Error: No packages in any requested group available to install or update

Running yum groups mark install prints Error: Need a group or list of groups and a lot of options.
I tried re-running the script (a few different ways) but no luck.

Script was freshly grabbed from
Maybe the groups generation got broken again?

OS type and version CentOS 7
Webmin version ???
Virtualmin version 6.2.2

I don’t see how. The group exists and is correctly named:

Did you yum clean all? If you’d tried to install previously it may not have re-downloaded the groups.

Also, you probably shouldn’t be installing CentOS 7 at this point in history. It’s quite old. I’ve posted a beta installer that works on Alma/Rocky a few times, at least I think it’s still working…I’ve been refactoring the VM7 repos heavily lately, but tried to keep the old layout working for now.

1 Like

Went for a re-install from scratch and that worked… so probably forgot a yum update somewhere, or something… thanks for looking.

Before you run any install, the best would always be is to:

  1. Sync datetime by running either systemctl restart systemd-timesyncd or systemctl restart chronyd depending on your system
  2. Check that the time has really synced by running date command (can take upto 10-15 seconds)
  3. Clear package manager cache by running apt-get clean or dnf clean all
  4. Run package upgrades with apt-get upgrade or dnf update
  5. Run Virtualmin -h script to check on the available options
  6. Run Virtualmin install with preferred options

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.