Installing mosh on centos

Dear all, I am trying to install mosh on Centos 6 but it’s on EPEL repository. When I add EPEL repository, yum update brings a lot of update notifications, which, I think will cause problems if updated.

Would anybody, please, recommend a way to install mobile shell using EPEL repository without breaking programs from Virtualmin repository?

Another way is to install from source, however, it requires lots of dependencies which are not available with yum commands, as well. I tried a few times but was not able to find dependencies to work with configure command.

Any help is highly appreciated.

Howdy,

If you temporarily enable the EPEL repo, and tell yum to install mosh – what dependencies is it trying to bring in with it?

I’m curious if those are things that would overwrite packages already installed, or whether they’re completely unrelated to what’s already on your system.

-Eric

Hi, Eric.

I didn’t think of enabling EPEL, installing mosh and disabling EPEL. Thanks for teaching it to me! :slight_smile: It’s now installed.

Dependency problems arose when I tried to install from source. With EPEL yum did the magic.

I’m so grateful!