Installing Authen::Libwrap CPAN module

Tried to install ‘Authen::Libwrap’ multiple times in vain.

Installed all the modules except ‘warnings’ as per http://deps.cpantesters.org/?module=Authen%3A%3ALibwrap;perl=latest

This is the error I get:
[ CPAN.pm: Building D/DM/DMUEY/Authen-Libwrap-0.22.tar.gz

enter include directory to use: [/usr/include ]
/usr/include
enter library directory to use: [/usr/lib ]
/usr/lib
Created MYMETA.yml and MYMETA.json
Creating new ‘Build’ script for ‘Authen-Libwrap’ version ‘0.22’
Building Authen-Libwrap
Error: Function definition too short ‘/ * EOF * /’ in Libwrap.xs, line 32
gcc -I/usr/lib64/perl5/CORE -DXS_VERSION=“0.22” -DVERSION=“0.22” -fPIC -I/usr/include -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -o lib/Authen/Libwrap.o lib/Authen/Libwrap.c
lib/Authen/Libwrap.xs:9:18: error: tcpd.h: No such file or directory
lib/Authen/Libwrap.xs: In function ‘XS_Authen__Libwrap__hosts_ctl’:
lib/Authen/Libwrap.xs:24: warning: implicit declaration of function ‘hosts_ctl’
error building lib/Authen/Libwrap.o from ‘lib/Authen/Libwrap.c’ at /usr/local/share/perl5/ExtUtils/CBuilder/Base.pm line 175.
DMUEY/Authen-Libwrap-0.22.tar.gz
./Build – NOT OK
Running Build test
Can’t test without successful make
Running Build install
Make had returned bad status, install seems impossible
Failed during this command:
DMUEY/Authen-Libwrap-0.22.tar.gz : make NO
]

Would appreciate any help in successfully installing this module.

Well, I’m not sure if this is the same issue I ran into (time and time again) until I figured out why it wouldn’t compile and install properly.

I needed to manually install a few prerequisite packages first and then Authen::Libwrap perl module compiled and installed fine.

apt-get install libwrap0 libwrap0-dev