Installed PostgreSQL still appears under Webmin > Unused Modules

OS type and version Debian 10 amd64
Webmin version 1.994
Virtualmin version 7.1-1
Related packages Webmin, PostgreSQL

I created a test virtual Debian server with Virtualmin, then ran the post-installation wizard. In the wizard, I selected no database since I wanted to use PostgreSQL and it was not installed. Under Enabled Features, PostgreSQL was not selected. I don’t remember if this was by choice or forced because PostgreSQL was not installed at that point.

After running the wizard, I went to Webmin > Ununsed Modules > PostgreSQL Database and created a new DB. Later, (after posting a query and help from Joe), I enabled PostgreSQL in Edit Virtual Server > Enabled Features. A default database was created with the DB admin user’s name.

When I look back at Webmin, PostgreSQL is still under Unused Modules. I would have expected it to be moved to Servers after installation.

Feature or bug? Just curious.

Click “Refresh Modules” in navigation menu (at the bottom).

1 Like

Ok. Sorry that I did not see that. Thanks for your help.

BTW, I expected, erroneously, that it would be “corrected” after a logoff-logon. Probably best left as is.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.