Install stuck on fatal error

I’m installing (err, trying to install) vm on a new centos lamp server at vps.

I’ve installed vm on a centos lamp before, a few years ago, without any trouble, but for some reason this time, I am getting:


INFO - 2012-01-15 15:09:22 - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-utils caching-nameserver h
ttpd postfix bind spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-serve
r mysql-devel postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-domxl php-gd php-imap php-m
ysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyr
us-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay
Loading “protect-packages” plugin
Loading “kmod” plugin

FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log


any suggestions?

Thanks, Chris

Log just says:

INFO - 2012-01-15 17:39:35 - Disabling SELinux during installation…
INFO - 2012-01-15 17:39:35 - setenforce 0 failed: 1
INFO - 2012-01-15 17:39:36 - Download of http://software.virtualmin.com/gpl/rhel/5/i386/virtualmin-release-l$
INFO - 2012-01-15 17:39:36 - Succeeded.
INFO - 2012-01-15 17:39:36 - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-u$
Loading “protect-packages” plugin
Loading “kmod” plugin
FATAL - 2012-01-15 17:39:37 - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - 2012-01-15 17:39:37 - Cannot continue installation.

Howdy,

It looks like the yum command is failing for some reason. Can you try running this manually from the command line – I’m curious what output you receive:

yum -y -d 2 install bind bind-utils caching-nameserver httpd postfix bind spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-domxl php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay

Wow, took me all day, but I got it.

What I figured was I probably should not have gotten the LAMP version, as I read it should start with a clean install. Had to actually redo it several times, kept having a problem getting to the webpanel after the install. It may have had something to do with my ssh sessions timing out, I don’t know. I don’t think it should have. But the time it finally worked was the one time I was able to keep the session alive.

Started this morning thinking I could get it up and running in a few hours, now it’s almost midnight - yikes!

Sorry I did not take you up on running that yum command, had already moved on when I got your note.

Great, I’m glad you got it working!

-Eric