does not finish on Ubuntu 10.04

I have been playing around with Amazon EC2, installed a copy of Ubuntu 10.04 LTS and tried to install a copy of Virtualmin pro via both the script and manually. In both circumstances virtualmin does not install. Webmin and all the supporting packages install fine, but virtualmin does not.

The specifics of the server are Ubuntu 10.04 LTS Lucid EBS boot, 64-bit. The specific ami is: ami-22423c70

Ideally I’d like to transfer my hosting to EC2 on a ubuntu server, so any help would be appreciated.


What error(s) do you see when it goes through the installation? If you could paste in any errors you’re seeing here, that’d be super.

Also, if you could attach your /root/virtualmin-install.log, that’d be helpful as well!



Funny thing is I couldn’t see any errors. Everything goes along fine, but Virtualmin never gets installed. I’ve attached a copy of the install log with obfuscated domain and IP’s. Its the log of a few install attempts so its quite long.

According to the log virtualmin-base gets installed , but /etc/virtualmin and /etc/init.d/virtualmin do not exsit. Also does not resolve.

I didn’t get a chance to have a look over the other logs: syslog, aptitude log etc. But if you think it would help I can try another install and cut out the relevant data.

Otherwise I would be happy to give you access to the server, if your willing to have a look. If so, what email should I send the login credentials?


Actually, that install log all looks pretty good.

Remember that Virtualmin is a Webmin module, so what you’d be doing is making sure Webmin is started up… you can do that with:

/etc/init.d/webmin restart

Then, try browsing to your IP address and port 10000:


If you browse to the above IP and port 10000, do you see the Webmin/Virtualmin login screen?


I also can’t see any errors in the log (at least none that would prevent Webmin from running, there seems to have been an issue with Mailman though).

How did you determine that “virtualmin was never installed”? The log suggests otherwise:

Selecting previously deselected package webmin-virtual-server-theme. Unpacking webmin-virtual-server-theme (from .../webmin-virtual-server-theme_7.9_all.deb) ... Selecting previously deselected package webmin-virtualmin-awstats. Unpacking webmin-virtualmin-awstats (from .../webmin-virtualmin-awstats_4.4_all.deb) ... Selecting previously deselected package webmin-virtualmin-dav. Unpacking webmin-virtualmin-dav (from .../webmin-virtualmin-dav_3.3_all.deb) ... Selecting previously deselected package webmin-virtualmin-htpasswd. Unpacking webmin-virtualmin-htpasswd (from .../webmin-virtualmin-htpasswd_2.3_all.deb) ... Selecting previously deselected package webmin-virtualmin-mailman. Unpacking webmin-virtualmin-mailman (from .../webmin-virtualmin-mailman_5.8_all.deb) ... Selecting previously deselected package webmin-virtualmin-svn. Unpacking webmin-virtualmin-svn (from .../webmin-virtualmin-svn_4.7_all.deb) ...

How did you try to access the Webmin interface?

Is Webmin running? /etc/init.d/webmin status

Is Webmin listening to its port? netstat -ltpn | grep 10000

Maybe a firewall / packet filter / iptables problem?

Its a bit embarrassing, but I thought virtualmin creates its own process rather then run under webmin. Worst thing is I’ve been using virtualmin for over a year and it still didn’t click.

Webmin is running and is bound to port 1000, looks like that is working fine. Connecting without ssl brings up the standard go to https page, but when I try to go to https://x:10000, it doesn’t work.

I can’t remember removing anything that might have affected ssl, but I did do a few things prior to trying to install virtualmin. I’m going to try fire up a new Ubuntu instance and try again without changing anything before hand.

Thanks once again for your fast help!

After all that I’ve worked out the problem… I have all my web traffic running through a Polipo proxy on my local machine for performance. But when trying to access virtualmin via https it doesn’t work.

For my previous server I had to disable the proxy on my virtualmin address, but this time around I had completely forgot about it. All this time I had been looking through the server when the problem was right on my machine.

Thanks for putting up with me!

Glad you got it working, thanks for the heads up!