Install Scripts menu missing for root?

I dont have Install Scripts menu on my Dashboard here the screenshot

Missing that All Important SYSTEM INFORMATION (Like OS and Version info)

Try Virtualmin -> System Settings -> Script Installers

Or simply
Virtualmin -> Install Scripts
Screenshot 2024-01-01 151915

You need to install Virtualmin using virtualmin-install.sh script:

https://www.virtualmin.com/download/

That’s a webmin system not a virtualmin system. The op needs to install virtualmin

1 Like

Hello Ilia should I remove Webmin and install it again using .sh ?

I guess that would have been obvious - It is still prompted for when you make a post on here. It is so easy to copy the dashboard and paste the info. The forum even has a simple icon to do it for you.
Screenshot 2023-10-16 163047

Hello Ilia should I remove Webmin and install it again using .sh ?

You haven’t given us enough information to give you good advice.

You talk as though you expect to see Virtualmin menus, but the screenshot is Webmin without Virtualmin. Did you install Virtualmin using our install script or did you just install Webmin? If you just installed Webmin, you should not expect to see any Virtualmin menus, because the Webmin package does not include the Virtualmin modules, and to have a functional Virtualmin system a bunch of extra stuff needs to happen (other packages, configuration changes, etc.), which is why we provide an install script.

If you need Virtualmin, you should install it using our documented procedure for installing it: https://www.virtualmin.com/download/

If, on the other hand, you did install Virtualmin and used to see Virtualmin menus but now don’t, something else has gone wrong and you’ve removed Virtualmin access for the root user (or worse, uninstalled Virtualmin), which is a more complicated problem to solve.

It is always better to start off a clean OS.

Hello Ilia should I remove Webmin and install it again using .sh ?

THank you now I have new issue here the screenshot

That means you didn’t start with a freshly installed OS or there were errors during installation that you ignored. Please just follow instructions.

https://www.virtualmin.com/download/

yes I install it and now I have new issue by trying to install RoundCube I have this red error

and I already have PHP 7.4 :

PHP 7.4.3-4ubuntu2.19 (cli) (built: Jun 27 2023 15:49:59) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.3-4ubuntu2.19, Copyright (c), by Zend Technologies

I replied you here:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.