install script fails

I just had my server OS reinstalled again - but this time with NO LAMP install done so that the Virtualmin install script can install what it wants… When I try to run the Virtualmin install script, the script fails with:

=> `’
Resolving… failed: Name or service not known.

As I have screwed up the last two installation attempts could you help with this one? The SSH logins for my server are:

IP address:
ID: nmournian
PW: tanZan1a.99

The FQDN should be set to


Sounds like DNS isn’t working on your server – that’s an easy fix! Just make sure there is at least one nameserver listed in /etc/resolv.conf.

You’ll have to do that part though, as we don’t know what the nameservers your ISP gave you are.

So pop in one or more nameservers, re-run the install, and we can work from there :wink:


I created a /etc/resolv.conf file and wrote:

and saved the file.
I tried to run the script using sudo apt-get but the same error pops up.

I edited the resolv.conf file to read:

(which are the servepath ns addresses) and the script worked. the truth is Virtualmin has NEVER worked this fast before… I’m running a bulk server create script and it’s kicking out new virtual servers way faster than any of the other installations I’ve worked with. Guess there’s nothing like a truly virgin installation!
Thanks SO MUCH for the tip on resolve.conf!!!

Sorry I haven’t been of more assistance today, I haven’t been feeling too well… however, I’m glad it’s working for you!


It looked like having a virgin ubuntu install worked at first but then I started a bulk list running in the Create Virtual Server screen… a couple of hundred virtual servers were created without seemingly any issues.
The CPU however was using all available memory and virtualmemory. I rebooted the machine to get the remaining list to stop running. (Memory available is 1GB and 2GB Virtual Memory.) When I did that the machine and all services came back online BUT apache and BIND will not start. The error message at first was that it couldn’t bind to that address, I added ServerName to the httpd.conf file and the error has changed but apache and bind are still dead.
The new message is:

Failed to start service :

  • Starting web server apache2

Bind error is:

Failed to start service : Failed to start BIND : Unknown error

But the BIND error is given when I’m using the start BIND function and apache2 is of course not running.
All the other services seem to be ok…
Any ideas? This install was completely handled by Virtualmin - even let it ask for the FQDN instead of entering it manually.

I have enabled your remote login…

SSH login is the same…

I now have a red banner across the virtualmin System Information page… it says:

A problem was detected with your Virtualmin license :
Your serial number is licensed for only 1 servers, but is being used on 4.

I have the licence copy on this machine but not on 4! Is this part of the problem? Is it possible to find out where the other machines are (if indeed this is not an error?) Thanks for your help!


First off, the license error isn’t the issue here; Virtualmin won’t just shut off services. It’s likely just confused over being reinstalled recently, and will likely clear up in a few days.

Regarding the BIND and Apache errors –

I’m not sure what exactly happened there… if it perhaps wasn’t finished the import, if it was doing something else, or if it was a bug – I dunno.

However, there were two things that I changed:

  1. BIND seemed to have a couple of entries that were duplicated. I removed the duplicate entries, and it starts up okay now.

  2. It took a bit to figure out the Apache problem, but it seems to be related to a max open files problem. There’s probably a much better way to solve this, but in the meantime, I added this line to your Apache init script: ulimit -n 16384

At this point, both BIND and Apache are running.


I saw the server up but when we rebooted it we get a partial Virtualmn/webmin interface and the error (in both left and main panels:

Failed to open /etc/webmin/apache/site for writing : Bad file descriptor

SSH is up
Web server seems to be down
ftp server seems to be up

Aha! I see part of the issue.

After poking around a bit to see why Webmin wasn’t running, I see this in the kernel logs:

[ 5850.659134] EXT3-fs error (device sda1): htree_dirblock_to_tree: bad entry in directory #2310627: rec_len % 4 != 0 - offset=0, inode=1970562386, rec_len=28274, name_len=45 [ 5850.659212] Aborting journal on device sda1. [ 5850.659789] Remounting filesystem read-only

So, it looks like there may be some hard drive issues going on.

Webmin isn’t starting, as the filesystem is currently mounted read-only.

And according to the above error, that’s because of some drive errors detected recently.

My recommendation would be to reboot into single user mode, and to run a e2fsck on /dev/sda to look for any disk problems.


Thanks for checking into that for me. Were you still online when the server was rebooted? Had you made any changes to your files at that time? Just trying to get all the data together in one spot to hopefully resolve this today…

When you rebooted the server earlier today when this all came up, I was not logged in.

If you rebooted the server just recently – yes, I do think I was logged in then, but no, I had not made any changes. I had just looked around a bit to see what the issues were.

In fact, I couldn’t have made changes even if I wanted to, due to the filesystem being marked read-only :slight_smile:

Does that answer your question?


We got the server back online, but the Servepath tech forwarded this error:
(apache won’t start)
Your server did require an fsck which fixed a number of filesystem journal errors. Your server is now online and accessible.

I did notice that apache did not start due to a syntax error:

Syntax error on line 18 of /etc/apache2/sites-enabled/ can’t get fastcgi file info: /home/usincomescom/fcfgi-bin/php5.fcgi(/homeusincomescom/fcgi-bin/php5.fcgi), errno: 2

When I login to Virtualmin and attempt to start the apache server, the following error shows;

Failed to start service :

  • Starting web server apache2
    Warning: DocumentRoot [/home/usincomescom/public_html] does not exist
    Syntax error on line 18 of /etc/apache2/sites-enabled/
    can’t get fastcgi file info: /home/usincomescom/fcgi-bin/php5.fcgi(/home/usincomescom/fcgi-bin/php5.fcgi), errno: 2

It looks like the home directory for the Virtual Server “” does not exist.

You may want to try restoring that Virtual Server again, or removing the “/etc/apache2/sites-enabled/” file that tells Apache to serve files for that site.