Install Problem on Debian

Brand new Debian etch install and Virtualmin Pro. Install script fails at what looks like a bind9 dependancy problem. If I try and install bind manually I get:

#apt-get install bind9
The following packages have unmet dependencies:
bind9: Depends: libdns22 (= 1:9.3.4-2) but 1:9.3.4-2etch1 is to be installed
Depends: libisccfg1 (= 1:9.3.4-2) but 1:9.3.4-2etch1 is to be installed
Depends: libisc11 (= 1:9.3.4-2) but 1:9.3.4-2etch1 is to be installed
Depends: libisccc0 (= 1:9.3.4-2) but 1:9.3.4-2etch1 is to be installed

Fixed. Changing my apt/sources.list to another mirror cleared things up.