Install failure but solved now.

Thought I would post this here by way of a heads up. Probably something I did wrong but …

I decided to start from scratch on the server and returned to a clean CentOS 5.3 install.

This time, because I had a pro licence I decided to download the install.sh from the licence page.

So, I installed Webmin, checked things were looking ok, then tried to install Virtualmin.

I got the following error :

INFO - Operating system version: 5 INFO - Configuring package manager for CentOS Linux 5... INFO - Disabling SELinux during installation... /usr/sbin/setenforce: SELinux is disabled INFO - setenforce 0 failed: 1 INFO - Download of http://5556956:@software.virtualmin.com/rhel/5/x86_64/virtualmin-release-latest.noarch.rpm Succeeded. error: open of <!DOCTYPE failed: No such file or directory error: open of HTML failed: No such file or directory error: open of PUBLIC failed: No such file or directory

Cutting the story short, I downloaded the GPL install.sh and it ran without error. Obviously I then enabled the Pro features.

As I said, just a “heads up” really.

It looks like the license key is cut off – I only see the serial number mentioned there.

An example of what could cause that is downloading the install.sh from the command line, but not putting the URL within ticks.

Make sure if you’re downloading it from the command line, that you’re using something like this:

wget ‘http://software.virtualmin.com/cgi-bin/install.cgi?serial=NNNNN&key=XXXX&pass=

That is, it needs to be within single quotes, or bash could try to interpret the & in the line – preventing the key= part from working.
-Eric

Ah ha !

That was the problem.

Here is the line from .bash_history (edited of course)

wget http://software.virtualmin.com/cgi-bin/install.cgi?serial=NNNNNNN&key=XXXXXX&pass=YYYYYYYY

Thanks for proving it was my fault again. :wink: