Install Drupal not finding mysql

I have just installed virtualmin on a ubuntu 10 server and setup a virtual host. I then tried to install drupal and received the following error:

Database configuration
Your web server does not appear to support any common database types. Check with your hosting provider to see if they offer any databases that Drupal supports.

When I check in virtualmin there is a database named after the host I also created a new one but still the drupal install does not find it.

Any help would be great I don’t even know where to start.


You may be missing the PHP MySQL module.

That’s easy to get working though… you can log into your server via SSH, and type:

apt-get install php5-mysql

Ok I installed php mysql but it is still the same.

If it helps you can view the php config info
I notice that the php.ini is not being read from the vhost folder also no MySQL is showing in the configuration.

Hmm, I don’t seem to be able to connect to that page.

However, are you by chance using mod_php? If so, you may need to restart Apache after making changes such as that.

Alternatively, you may want to look into moving to cgi or fcgid… you can do that by going into Server Configuration -> Website Options, and changing the PHP Script Execution Mode.


Ok I have no real idea why but it’s all working now - I think.
Could someone please see if they can reach the site at

I am on an internal lan and can but I would like to be sure that others can.


Well, I’m glad to hear that your app is working! Though, I still don’t seem to be able to access the site, so something may be awry in that regard.

My guess is that either dyndns isn’t pointing to the right IP address, or you need to configure your router to forward port 80 into your Virtualmin server.