"Index Of" with a new virtual server

Not sure what the correct question is.

What is the cause of the “Index Of” listing on the home page of a newly created virtual server? I don’t know what I need to address/fix.

I created a server in my office with an old machine. Installed particulars and Webmin/Virtualmin. No issues. I can create virtual servers at will no issues. I am using DNSExit service to point to my IP address. Basically, all of the default installs and configs work and I don’t need to become a network expert.

Now I have a VPS at Godaddy (all domains are registered there) and installed Webmin/Virtualmin without issues. When I create a new virtual server, exactly like my office server the home page of the new site renders the “Index Of” page. I tried a VPS at a different hosting company and had NO issues, but I ended up not agreeing with TOS.

The point is WM/VM works as expected 2 out of 3. So what is different at Godaddy? My guess is a DNS/Nameserver issue. But, I don’t know enough networking to know what needs to change.


UPDATE: I found info about the DocumentRoot. And it turns out the virtual server is grabbing the index.html from the default: /var/www/html. So, I took a peek at httpd.conf. The virtual host section has the directory listed of the files should be loading. Is there something causing Apache to ignore?


If the domain you’re going to is setup in Virtualmin, but it’s pulling up the wrong site – then you may be seeing this issue here:


Take a peek at that, and see if those tweaks help with the issue that you’re seeing.


I followed the article.

After making tweaks and restarting/rebooting, No joy. Also Deleted the domain and recreated with no joy.

I’ve also been comparing everything I can think to my office server and the only glaring difference I can see is the office server has IPV6 turned on. But the Godaddy VPS doesn’t have it on or enabled. I don’t recall doing anything on either box. And I’m not sure this is the lynch in pin anyway.

The apache virtualhost sections are slightly different.

The office server has:

<VirtualHost *:80>

next section has the local IP as exptected.

Godaddy VP only this:


BTW: I am using a different domain than the one used as My hostname.