Index Of page


I migrated my VirtualMin from my own physical server to an Amazon EC2 server.

However, now every site only displays a page that says

Index of /

I have done a re-check config and get no errors, and the apache logs show no errors either.

I’m not sure what else to check.

Here are the results on my re-check config

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 3.45 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
BIND DNS server is installed, and the system is configured to use it.

Mail server Postfix is installed and configured.

Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module.

Apache is installed.

The following PHP versions are available : 5.4.16 (/bin/php-cgi)

Apache is configured to host SSL websites.

MySQL is installed and running.

ProFTPd is installed.

Logrotate is installed.

SpamAssassin and Procmail are installed and configured for use.

ClamAV is installed and assumed to be running.

Plugin Protected web directories is installed OK.

Using network interface eth0 for virtual IPs.

Default IPv4 address for virtual servers is

Default IP address is set to, which matches the detected external address.

Both user and group quotas are enabled for home and email directories.

All commands needed to create and restore backups are installed.

The selected package management and update systems are installed OK.

… your system is ready for use by Virtualmin.


Hmm, if you run “/sbin/ifconfig”, does the IP address you see for eth0 match the detected external address it’s showing?


Hi Eric, thanks for the reply.

No, looks like I have an internal address on eth0.

What should I do?

Ah, I suspect the issue is that Apache is still looking for a public IP address in it’s configuration – instead, it should be configured with your server’s private IP.

That is, in the Apache config, you’d want to look for the “VirtualHost” blocks that begin with something like this:

You’d want to make sure the x.x.x.x is the server’s eth0 IP address.


Thanks for the reply and I think we are on the right track.

It is using the external IP in httpd.conf

Should I edit this file directly?

In Virtualmin Configuration -> Network Settings

My settings are:

Network interface for virtual addresses: eth0
Default virtual server IP address:
Default IP address for DNS records: Automatically detect external address

If I change the default virtual server IP address to the internal address and then update the domains and I try to ping the domains from a different machine other than the server it returns the internal address which will not work.

Thanks for all the help with this.