Incremental backup same size of full backup

OS type and version Debian 11
Webmin version 2.105
Virtualmin version 7.9.0
Related packages SUGGESTED

Hi, after the upgrade to the latest version of VIrtualmin, the incremental Backup that I set on daily basis is not “incremental” is a full backup.

I have the following schedules:
FULL on Sunday;
INCREMENTAL from Monday to Saturday.

As you can see, the size is almost the same.

A have the same behaviour on all the 4 servers that i manage with Virtualmin.

How can i fix it? Any help is appreciated…

Not seeing that on mine.

OS type and version Almalinux 9 and Centos 7
Webmin version 2.105
Virtualmin version 7.9.0 Pro
Related packages Backup

I’m observing the same behavior on my servers. Incremental backups are taking up the same amount of space as the full ones.
Could it have something to do with the backup destination? In our case, we are performing them on S3.

Im backing up to S3, are you using a date in the backup name, I think it needs that to know what you last full was, just a guess.


Which compression format is used for backups?

Hi Robert, the destination is an FTP server, no fancy stuff…

Hi Ilia,
there are the settings for the Incremental Backup:

and these are the settings for the Full Backup:

Compression format is on default in both schedules.

Alright, but which format are produced backups, i.e. zip or tar or something else?

1 Like

The resultant backup is a .tar.gz

I’m using a date in the backup name too.

And the default backup compresion format is gzip.

Weird, same as what I’m doing and I have no problems. tar.gz as well

slight difference

I’ve the same settings as Nikkio. The only difference is the action on error. Could it be the ‘Create destination directory?’ option? I’ll do a test

Whats about Destination Directory, I’ve never enabled that yet it still creates a directory on S3. Maybe a bug.

I observed the following long time ago, and it hits me now and then. But,
it’s not always, only on some server or condition I cannot deterministically find out:

  • incremental backups are running fine
  • full backups run fine
  • after a reboot, which is not before a full backup:
  • all of the following incremental backups will be full size backups
  • If I do not check or have not enough backup space for 7 full backups a week,
    (instead of one full and six incrementals) - we run out of space

So I would be interested to get your answers to: when exactly was your last reboot,
may be due to the last security updates?


my last reboot was a week after the full backup.

Looking into the backup logs, I have found this behaviour after the upgrade to VM 7.9.0.

I unchecked the ‘create destination directory’ option, and I also deleted all the files in /var/webmin/modules/virtual-server/incremental/ just in case there was something wrong with them. Then I did a full backup, and the next day, an incremental one, but the behavior is the same as before the change.

Made by Started Run time Final size OK?
root 02/14/2024 12:00 AM 12:40:07 Incremental 700.31 GiB Yes
root 02/12/2024 07:29 PM 13:57:11 Full 717.48 GiB Yes

I think the incremental backup was working correctly until mid-December.

I have found a post in the forum that could be related to our problem: Backups not incremental for chrooted domains - Virtualmin - Virtualmin Community

I’m chrooting my domains. What about you, nikkio?

Yes, my domains are chrooted too.
The issue started ad December too, the day after virtualmin update.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.