Incorrect disk space reported in VM

In a CentOS 6.2 (both host and guest) KVM setup, I have the disk space (in the VM) showing as TWICE what it actually is (via system information). I already tried rebooting the VM. See

In the host, the only disks that exist (mounted on LVM) are:

cd /var/lib/libvirt/images/
ls -al
total 30817412
drwx–x–x 2 root root 4096 Jun 13 09:39 .
drwxr-xr-x 9 root root 4096 Jun 26 01:50 …
-rw------- 1 qemu qemu 8589934592 Jun 27 15:27 kvm1-1.img
-rw------- 1 qemu qemu 21474836480 Jun 27 15:28 kvm1.img

In the guest,

df -h
Filesystem Size Used Avail Use% Mounted on
19G 8.9G 9.1G 50% /
tmpfs 3.2G 0 3.2G 0% /dev/shm
/dev/vda1 485M 90M 370M 20% /boot

>cat /etc/mtab /dev/mapper/vg_centos62-lv_root / ext4 rw,grpquota,usrquota 0 0 proc /proc proc rw 0 0 sysfs /sys sysfs rw 0 0 devpts /dev/pts devpts rw,gid=5,mode=620 0 0 tmpfs /dev/shm tmpfs rw 0 0 /dev/vda1 /boot ext4 rw 0 0 none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0 /tmp /tmp none rw,bind 0 0 /var/tmp /var/tmp none rw,bind 0 0 /home /home none rw,bind 0 0

the only thing I’ve done recently regarding disks was set “barrier=off” option in grub

How do I get Webmin to correctly read disk space?


Logical Volume Management & Partitions on Local Disks show everything correctly.



It’s possible that you’re seeing a bug of some sort – I’d suggest filing a support request using the Support link above, and Jamie can work with you to sort all that out.

Be sure to include all the relevant info in your support request (as you did above) – including the Virtualmin and Cloudmin versions you have there, any screenshots, and what Linux distribution(s) you’re using.