Incomplete DNS zone files (using create-domain.pl)

Hi everyone.

Using virtualmin on a single IP address server (say IP=1.2.3.4), I have a probleme when I try to batch domain creation with create-domain.pl :

/usr/share/webmin/virtual-server/create-domain.pl --domain foo.com --user foo --pass "PassWord" --dir --unix --web --dns --webmin --template "Default Settings" --limits-from-template --default-features

Beginning server creation …

[…]

Adding new DNS zone …
… done

[…]

All done!

But when I look at the /etc/bind/foo.com.hosts file :
$ttl 38400
@ IN SOA srv1.mydomain.com. root.srv1.mydomain.com. (
1182960350
10800
3600
604800
38400 )
@ IN NS srv1.mydomain.com.
foo.com. IN A
www.foo.com. IN A
ftp.foo.com. IN A
m.foo.com. IN A
mail.foo.com. IN A
foo.com. IN MX 5 mail.foo.com.

If I try any ip-related option, either it gives me the same result, or it returns an error.

When I create a domain (bar.com) with the webmin interface, the /etc/bind/bar.com.hosts is correct :
$ttl 38400
@ IN SOA srv1.mydomain.com. root.srv1.mydomain.com. (
1182960350
10800
3600
604800
38400 )
@ IN NS srv1.mydomain.com.
bar.com. IN A 1.2.3.4
www.bar.com. IN A 1.2.3.4
ftp.bar.com. IN A 1.2.3.4
m.bar.com. IN A 1.2.3.4
mail.bar.com. IN A 1.2.3.4
bar.com. IN MX 5 mail.bar.com.

Forums and on-line documentation are not very verbose about the create-domain.pl command, so I’m kind of stuck here.
Does anybody have any idea of what I may have done wrong or what I may give a try (misconfiguration, environment needed, further reading, etc.) ?

Regards.

Simon Walter.

Hi again.

Maybe I forgot a couple of useful pieces of information :
Virtualmin 3.42
Webmin 1.350
Debian 4.0 Etch