Does anyone have a “how to” to either subscribe to the spam special folder or deliver mail to INBOX.spam so that it shows up in Thunderbird.

Would prefer a sever wide solution.


Hmm… I don’t fully understand your question I must admit. :slight_smile: Actually, the default setting is to put spam into a folder “spam” in the user’s mailbox (which Thunderbird probably lists as “INBOX.spam”). Configurable per-domain in the Spam and virus delivery.

What’s exactly the problem with subscribing to the spam folder? You subscribe to it like to any other IMAP folder. :slight_smile:

The problem is that Tunderbird doesn’t see the spam folder that is created by default but it will see INBOX.spam. So I’m looking for a way to deliver the spam to that folder so that I don’t have to go into Usermin to clean out and check my spam.

I’ve tried setting the Spam and virus delivery to ~/Maildir/INBOX.spam/ but it just delivered the spam directly to my inbox. I’ve got it set to INBOX.spam/ to see if that works any better.

But once I get this working, is there a template that I can alter that will set this globally on my server for all domains rather than having to make this tweek to every domain?


But where does Thunderbird get this folder name “INBOX.spam” from? It should only list folders that the IMAP server offers for subscription, and not “make up” folder names I think? Maybe try reloading the folder list? And if the folder that it sees is in fact the Virtualmin spam folder, maybe only incorrectly labeled, it should be the one that the spam messages to go. Did you check that maybe?

Default settings for spam mail delivery can be set under Virtualmin configuration -> Spam filtering options.

Ummm, your theory might be valid. However the problem still stands. How do I make the special spam folder that is created by the server show up in Thunderbird. Its a royal pain in the ass to have to switch to a web app just to check my spam folder.

So basically is their any way I can map/subscribe the special spam folder to a user defined folder that Thunderbird will see.


For Thunderbird you need to specify ~/Maildir/Junk/

This is a rather weird behavior of Thunderbird then though. Usually, every IMAP folder that the server offers should be visible in the client and available for subscription.

I personally use TheBat, and I can see the “spam” folder just fine. :slight_smile:

I’m using Thunderbird 3.1.6 on OS 10.6. Might be a quirk of Thunderbird.

One other thing I found which might be a bug of Virtualmin is that when I specify a folder to deliver the mail to eg ~/Maildir/.Junk/ it delivers the email to my inbox. The SpamAssassin settings of Thunderbird is what made me think that I had gotten the config correct. Seems like I haven’t when I turn off the spam controls in ThunderBird, I see all my junk mixed in right along with my ham mail.

Hmm… Sounds odd indeed. Maybe Thunderbird interprets more than the “root maildir” as the “inbox”. I’ll test that out later with TheBat.

I noticed the default was to put the mail in “Maildir/spam”, which should have been “mail/spam” on my system. Once I told it that it worked fine, in Tbird too.