Impossible to connect to Webmin after it is installed by Cloudmin

I installed CentOS 7 on a new physical machine that I connected to Cloudmin through SSH keys. If I add it as a new KVM host, and let Cloudmin install Webmin, the bridge, and the KVM software, then, although I can see the login page I cannot connect to Webmin as root with the password (which works with SSH).
Is it a known bug?
I can see root in /etc/webmin/webmin.acl, and it is the only user there.
Is there a way to fix it or should I try to do a fresh install and set it up connecting with password instead of SSH keys?
Many thanks!


You need to make sure that nothing blocks default Webmin port 10000. If you have an error message on the browser saying: CONNECTION TIMED OUT, it might be the sign of connection being blocked for this port.

Google it, as it has being discussed many times already.

Thanks for the answer but I do have the login screen, I can see it on port 10000 (which is opened), but just it doesn’t accept my root credentials (which work fine on SSH)
If I click “Open Webmin” from Cloudmin I get into Webmin, but if I go through the classic login screen on that same machine I get a login failed message.

You can change a password for Webmin user, following this small tutorial and its step #3.

Thanks it has worked. But it is a bug, no?
Cloudmin installs Webmin on the future host using an SSH key for authentication, shouldn’t it allow the root user to connect to it with its current password?

I am not sure exactly. I suspect that root password hasn’t been set at all, once you mentioned that you were using SSH key for authentication.

Yes it was set: the hosting company asks for it at the moment of the installation, I used it to connect to the machine and changed it myself through passwd (being root). Then I tried to connect with either (the first set password and the updated one), they don’t work.
I am going to do a retry without resetting the password (using the one set during installation) and will let you know.

I am using CentOS 7 for the host as I understood it is the most compatible with Cloudmin. Newer versions fail at setting up the machine as host (from Cloudmin) but if you think any other OS could worth a try let me know.

Thanks again

  • I have reinstalled a fresh CentOS 7.
  • I can connect through SSH with the password I have chosen while installing the machine
  • I go to Cloudmin and add the physical machine
  • I go on Hosts systems and I register it as a KVM Host, letting it do the installation of the bridge, webmin and kvm software and all go smooth:
**Setting up KVM host system ..**

Installing Webmin …
… done

Checking system status …
… done

Installing required commands …
… done

Installing KVM packages …
… done

Enabling CGroups …
… done

Loading KVM kernel module …
… done

Creating loopback device files …
… done

Setting up br0 network bridge …
… done

… setup complete! You can now add this system as a KVM host.

  • I reboot the machine
  • I go to https://[IP]/:10000 where I see the webmin login screen
  • I put root and my password in the login form
  • I get Login failed. Please try again.

So I will use the solution you gave earlier to set the webmin password. If I had used a password to connect to the physical machine instead of the SSH key I could have connected through the login screen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.