Import all data from an existing virtualmin installation without backup

Hi,

At this time I cannot boot an existing partition but I can see all the files. I’m creating the new VM and I want to know if is possible to import all my virtualmin configuration and data from an existing partition to a new VM. I don’t have backup done in virtualmin.

Thanks in advance.

Eric

That would probably be very tricky, since Virtualmin writes stuff to all kinds of configuration files. So either you try to copy over the /etc and /home directory from your previous installation, or you recreate the virtual servers (and their users and stuff) manually on the new system and only copy over their contents from the /home/DOMAIN directories.

If you can still see all the files on the previous installation, it might be easier to try and get it to boot again. What exactly is the problem in that regard?

Thanks,
I’m on Linode, the problem started when I tried to upgrade to new plans, I updated only the kernel to 64 bits, that was required, and deleted some unused partitions
I tried to boot the existing partition but had several problems:

  • fsck start when booting but never finishes, waited more than 10 hours for a 10 gb partition.
  • If I disable filesystem check on boot then it hangs at this point.

    md: … autorun DONE.
    EXT3-fs: barriers not enabled
    kjournald starting. Commit interval 5 seconds
    EXT3-fs (xvda): mounted filesystem with writeback data mode
    VFS: Mounted root (ext3 filesystem) readonly on device 202:0.
    devtmpfs: mounted
    Freeing unused kernel memory: 844K (ffffffff81c93000 - ffffffff81d66000)
    Write protecting the kernel read-only data: 12288k
    Freeing unused kernel memory: 452K (ffff88000178f000 - ffff880001800000)
    Freeing unused kernel memory: 1272K (ffff880001ac2000 - ffff880001c00000)

I worked with the support of linode, but at the end they recommend deploy a new distribution and mount the existing partition there.

Thanks,

Eric

Howdy,

You could always try setting up a new server using the same distro/version, install Virtualmin onto it, stop all the services running on your new server (especially Apache, MySQL, and Webmin), and then copy /etc, /home, and /var/lib/mysql from your old server to your new one.

Once that’s done, reboot and see if everything comes online properly.

I do suspect it’s possible to determine why it’s not booting, but I don’t see an obvious issue in the output you have there.

-Eric

Hi,

I did exactly this and almost everything was fine, except for mail. At the end I made virtualmin backups and restored in a new VM and everything was fine.

Thanks again,

Eric