IMAP Problem

Ok, Ive searched the forums and google and cant really find any answer to this one. It looks to me like IMAP is looking in the wrong place for email. Currently users in a domain are placed into /home/domain/homes/user.domain for their directory. It appears as though Dovecot IMAP is looking for mail in /home/user/maildir

As a result people checking via IMAP are not seeing email, but POP they are finding their email.

Are there any solutions to this?

Are there any solutions to this?

Of course. Configure Dovecot correctly. :wink:

You’ve told it to look for /home/$u/Maildir (or similar), instead of ~/Maildir. It actually defaults to the right thing on most platforms I’m familiar with, so it’s likely that changes you’ve made are the source of the trouble.

Uh… :slight_smile:

We didnt make any changes. Its a CentOS install using the install scripts provided here to my understanding.

Just in looking for a solution to the imap problem, I looked in the Dovecot config in Webmin, and it looked like it was defaulting to the directory mentioned above.

Being a bit new to this, Im assumign Dovcot looks for the mail for Pop or Imap based on a single setting, so why would one work but the other not.