IMAP configuration problem & more

I finally got virtualmin working - more or less.

First of all, there are two points missing in my virtualmin menu:
"Install Scripts" and "Edit web pages"

How can that happen?

Next problem is the more important one: I have set up a new mail box (user) and was able to fetch mail with that account. Even sending worked except for one thing: The sent folder.
Apple Mail tried to create a sent folder as inbox.inbox.sent - weird.
So I tried thunderbird, thunderbird tried to create inbox.gesendet (german for sent), which is weird, too… but at least at the right location. The folder was created, but thunderbird couldn’t save anything in it.

What’s going on here? Any ideas?

First of all, there are two points missing in my virtualmin menu: "Install Scripts" and "Edit web pages"

How can that happen?

You’ve installed Virtualmin GPL, which has neither feature.

As for your mail problem, we need to see the log entries when the client tries (and fails) at creating the send folder. /var/log/maillog or /var/log/mail.log is where to look.

Hey Joe, thank you for your amazingly quick reply!

That was a misunderstanding I guess, I thought the virtualmin showed in the video demonstration was the GPL one.

I solved the mail problem. Part of it was an Apple Mail problem, the rest a bug in the german translation of Thunderbird. All had nothing to do with virtualmin, I am sorry.

If anyone here has the same problems, this is how I fixed it.

  1. Delete all accounts from Apple Mail. Be sure to clean up ~/Library/Mail, too (if there are any things that belong to your accounts)
  2. Install Thunderbird ENGLISH (important!!)
  3. Add your accounts there, be sure to save a draft and send a mail there. It will create the default "drafts" and "sent" folder
  4. Now you can add you accounts to Apple Mail again. Be sure to tell the application to use the imap folders for sent messages / drafts via Mailbox-Use Mailbox For.

That’s it, everything’s fine now I think.

I just have to find where I can adjust the quota of a virtual server (not a mail account). Can’t be that hard.

you should be able to do that in the "server template"
and for existing domains in the "edit virtual server"

Thank you very much… but…

Strange here: I set the quota for one of the virtual servers to unlimited, still the status page claims: "640 kb of 1024 mb". Is that just out of date?

It is… now it’s correct :slight_smile: