I disabled the Feature BIND in feature and plugins and no longer accepts reactivation!

Hi guy’s, I am concerned, I ask your help.
I have a small VPS at OVH, and always had webmin in Digitalocean(ubuntu 14.04) no problems at all, now also in the new installation TOO with Ubuntu server 14.04 64bit at OVH. I can not activate the BIND feature, in features and plugins always gives the following message:
Failed to save enabled features: virtualmin is configured to set up DNS zones, but this system is not set up to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.
searching for it on the internet, I found some solutions how to create a file:
nano etc / dhclient-eth0.conf
prepend domain-name-servers; exit saving
I tried to add in Hostname and DNS Client but noting!
I need to reactivate this featured, what do I do?
Best Regards.

Add “” in resolv.conf.

thanks for answering Diabólico.
already I tried, and every time we reopen the file disappeared my entry:
I tried localhost
I tried
already tried

but nothing works.

but my changes automatically disappear.

I saw no solution on this, the posts always die!


You may want to see if this here helps:


I noticed something that may be important in this error.
tested in 3 different distros, any one of them is the first thing I always do in Webmin is to re-check when I’m signed on the panel for the first time, and all tests are always 100% right now … if I happen restart the machine without making the settings to create virtual server, this error comes and already was. does not come over like some. I can not reboot before creating a server because it will ask for me to create mailist for the mailman and then I create the first server, you can restart the machine. that nothing bad happens.
I will try what is described in the guide above.

It would be added as described… the name “domain-name-servers” is a parameter.

However, if you’re using DHCP, you could also just switch to using a static IP, which shouldn’t re-write the resolv.conf file.


THANKS!!! helped me a lot. THX Andreycheck is now working, I did exactly as it is there!