I can't upload and replace files using virtualmin file manager

OS type and version CentOS Linux 8.5
Webmin version 1.990
Virtualmin version 6.17
Authentic theme version 19.90.1


My problem is that I want to replace my files with new ones and there is no option to do that in the new Authentic theme version

For example if I have 1000 file in a folder and I want to replace 10-20 files at ones I upload them then I found that the files are renamed to file(1).jpg, file(1).css, file(1).php and there is no option to select replace existing files, the old version has an option to select replace existing files now it’s gone

it also a problem to select replace existing files every time in the old version but it’s better that this new version you can’t replace existing files

The only way to replace them is to delete them and upload the new ones again, its a time consuming

I think this is a bug I don’t now if @Ilia Didn’t notice this or not

I think the best way to make the uploader works for everyone is to add an option in file manager setting to whether you want to set replace existing files permanent to rename them, or if you select replace existing file to remember you choice next time so you don’t have to select replace existing files every time.

Please fix this problem soon as possible.



No, preventing overwriting files by default is a security feature and not a bug. However, this can easily be disabled on File Manager ⇾ Preferences: Advanced options page, using Do not overwrite existing files upon operations opton.


@Ilia Thanks for the quick reply, I checked the advanced options and didn’t notice there was an option for that.

So everything is fine now, Thank you for mentioning that.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.