I can't send email !!! Smtp trouble ?!

Using Centos 4.6 and Virtualmin GPL

I’m using the “user@domain.com” configuration to access to Pop3
but the same login / password don’t work when sending email (I’m using smtp auth, isn’t it ?!) and the mail client asking me user and password again and again…

any advice ?!?!?

thanks

L.

I know about the "@" thing on the FAQ, I mean:

On very new operating systems (Fedora Core 5 is confirmed to have this issue) the Cyrus saslauthd version defaults to dropping the "@domain.tld" portion of the username before attempting authentication. This, obviously, won't work. The solution is to add the "-r" flag to the saslauthd command. On Red Hat based systems, additional flags can be added in the "FLAGS=" section of the file /etc/sysconfig/saslauthd. This is an orthogonal issue to the Postfix issues, and will occur whether you use Sendmail or Postfix as your mail server.

but I wonder if I have to add also if I have Centos 4…

L.<br><br>Post edited by: umbrianet, at: 2008/07/31 23:37

That’s the symptoms you’d expect to see, if you didn’t have saslauthd configured for @domain.tld style accounts…so I’d guess the answer is: Try it and see. :wink:

But you would also see pretty clear indicators in the maillog. It’ll look like the user is authenticating with just their name rather than the full name@domain.tld.

Yes :slight_smile:

Now it’s work with the “-r” flag (after added I rebooted the service).

Thread closed.

:slight_smile:

ahhhhhhhhhhhhhhhhhhhhhhhhhhhh the server is hanging !!!

I can see in the process list so many lookup-domain.pl processes !!

can be a trouble about the "-r" option ?!

If i stop postfix now the server is working…

mmmm yes… I need help :slight_smile:

L.

it seems also that I have so many "clamscan" processes …

Not solved… but it seems that if I stop postfix the server is working fine…

any ideas ??!

L.

No, has nothing to do with the -r option.

Switch to clamdscan in the Email Messages:Spam and Virus Scanning page. spamc also wouldn’t hurt. You’ll need to start up the spamassassin daemon and clamd daemons first (there will be a button in the page for the latter, as it requires some extra steps…the spamassassin service can be started in the Webmin:System:Bootup and Shutdown page).

umbrianet wrote:

I know about the "@" thing on the FAQ, I mean:
On very new operating systems (Fedora Core 5 is confirmed to have this issue) the Cyrus saslauthd version defaults to dropping the "@domain.tld" portion of the username before attempting authentication. This, obviously, won't work. The solution is to add the "-r" flag to the saslauthd command. On Red Hat based systems, additional flags can be added in the "FLAGS=" section of the file /etc/sysconfig/saslauthd. This is an orthogonal issue to the Postfix issues, and will occur whether you use Sendmail or Postfix as your mail server.

but I wonder if I have to add also if I have Centos 4…

L.<br><br>Post edited by: umbrianet, at: 2008/07/31 23:37

thanks for your help

L.