I can't configure php8.2 in virtual

SYSTEM INFORMATION
OS type and version AlmaLinux 8.10
Webmin version 2.111
Virtualmin version 7.10.0 Pro
Related packages SUGGESTED

I have installed php8.1 in webmin but in one virtual I can configure it and use it but in another one it does not let me.

In Web Configurations > PHP Options the script execution mode is disabled and it won’t let me change it, it does the process but returns to the previous position.

Hello,

I think you should undo the steps you took to install PHP 8.1 and follow our tutorial to do it properly:

Thanks @Ilia
But i am thinking that i have something wrong installed because if i go to php Options i can only load the screen in a selected subdomain but not in the other domains in virtualmin

If I selected FPM shows me the following

 PHP Options
In domain komenta.me
Changing PHP execution mode to FPM ..
.. done
Changing PHP error log ..
.. failed : PHP error log cannot be set in none mode
Updating Webmin user ..
.. done
Restarting PHP-FPM 7.4 server ..
.. failed : Job for php74-php-fpm.service failed because the control process exited with error code. See "systemctl status php74-php-fpm.service" and "journalctl -xe" for details.
Applying webserver configuration ..
.. done
Re-loading Webmin ..
.. done

I think I need to uninstall and reinstall the php versions.

is there any manual on how to remove php versions?

You’ll want to uninstall all related packages with a command like:

dnf remove php82*

Thanks @Ilia for the ansewer.

I was able to uninstall the other versions of php!

But now where can I configure the php variables for example the max_upload and those because it does not allow me in virtualmin?

If I go to Web Configuration > PHP Options (PHP script execution mode) it only allows me to have it disabled.

In the PHP-FPM configuration

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.