I cannot preview a vitualmin website

I have been asked to review a website and have the login details but once in webmin/ virtualmin to view the site, it says virtualmin is ‘under construction’. Why is that? I do not have Wordpress on my computer. Do I need to have WP in order to view the site? I didn’t think so as I thought I should be able to view in using a web browser… HELP please!

Sounds like someone left the default index.html file in the public_html folder. Delete it or rename it.

1 Like

Thank you for your reply, can you direct me to the file pathway please. I will delete it if it doesn’t affect anything else/ the website

renaming did not fix the issue, still says ‘under construction’ ugh!

It’s in the public_html folder of the virtual server you’re trying to reach. So if you have a virtual server for your.web.site.com, you go to that virtual server, file manager, public_html and just delete the index.html file.


Deleting it has made no difference, I went into virtualmin- file manager- public_html and still not working. I hope I haven’t messed anything up at their end! ow to do I recover the deleted file just in case?

Did you clear your cache? If you’re running cloudflare, clear the cache there too. What’s the web address?

it says error message ‘403- I do not have permission to access on this server’ when I tried to use my mobile… and ‘under construction’ on my laptop.

What does the developer need to do grant my access?

OK, this is going to sound rude but it’s not meant to.

You clearly have absolutely no idea what you’re doing. The reason you’re still seeing the default html file is because you haven’t cleared your caches out. It’s not even there anymore. Use a different browser and you’ll probably see the same error as your phone.

The error 403 is usually because whoever set up the site didn’t know what they were doing. If it has Wordpress installed on it, chances are they screwed it up or never finished the install.

What you need to do is let someone that knows what they’re doing fix it. It’s abundantly clear you’re in way over your head.

As a last resort, you can try to get to the admin side of the site by typing in the web address and then put /wp-admin after it. If you see the login, then there you are. If you don’t, then whoever set this whole thing up messed up.

And frankly, that’s pretty hard to do because it’s a completely automated process.

I deleted the public_html and clear cache as you suggested and it now says:

‘Forbidden You don’t have permission to access / on this server.’

What do I do now?!!

Will I need to recover the deleted file? if so how do I do it?


You don’t need the index.html file. It’s useless to a Wordpress installation. In fact, it blocks you from getting to Wordpress if it’s left there. That’s why you delete it.

Try what I mentioned before and if you still can’t get anywhere then the guy who set the whole thing up messed up.

Can I ask, will it make a difference if I download wordpress installer? I do not have WP at all on my machine…

It is CLEAR that you have no idea what you’re doing. You don’t need Wordpress. You’re trying to access a Wordpress that someone else set up.

You need to stop and let somebody do it that knows what they’re doing before you really do screw something completely up.

Did you try to access the wp-admin as I said?

Of course it’s CLEAR! that’s why I posted in ‘Home for newbies’ !

Did you try to access the wp-admin as I said?- I did and it did not work so actually you ‘screwed something completely up’

Don’t respond to enquiries if you’re going to be rude, find another profession!

If you entered your web address followed by the /wp-admin and you still got an error 403 then then the odds are good that whoever set up the server has a firewall blocking the site. You also may have a port forwarding problem if you’re behind a router. It may also be a permissions issue.

The fact that you could see the index.html originally though leads me to believe that whoever installed the Wordpress did something wrong.

One other idea just came to me.

By default, Virtualmin will install Wordpress in a Wordpress folder. You have to actually tell it to install at top level. You can tell this by looking at your file manager of that server. If you see a bunch of folders in your public_html like WP content, WP Admin, etc, then it’s installed top level and should be working.

If you look in your public_html and see a folder named Wordpress, click on that and if you see all the wordpress files in there, then you need to add “wordpress” to the end of your web address.

So you would enter nameofyoursite/wordpress/ and see if that works.

Um, you mean index.html, don’t you?


It sounds like you’re pretty new to all of this (and that’s fine, sorry folks are yelling at you). Maybe starting from further back will help you understand it all better. I made an introduction video a while back that covers the basics of Virtualmin and installing a WordPress blog using the Virtualmin Install Scripts interface. That might help you get the pieces in the right place in your mental model of how all of this works (e.g. you’re way out in left field asking about installing WordPress on your local computer…that’s not how any of this works, and you need a reasonable conceptual model of what you’re trying to accomplish to ever be able to find your way there).

This one is also probably helpful for bringing you up to speed: Creating a Virtual Server (Domain) in Virtualmin - YouTube

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.