I broke something but not sure what

I set up a new server using Virtualmin with Apache for someone wanting to host their own websites on their own server. The server has been sitting several weeks after trying to get a python script; I don’t know python, working. I gave up on it. I also put Docker and Snap on the server. Today I added virtualbox to the server and rebooted the machine. Apache would not start and complained about a missing document root. When I went to the Virtualmin interface to remove the offending virtual server that was no longer needed, I got an error message: " Failed to query Postfix config command to get the current value of parameter sender_bcc_maps:" In order to get Apache to start, I went to the webmin side and manually removed the server from the Apache list. I started Apache but when I went to Virtualmin to remove the virtual server from the list; I get the same message: " Failed to query Postfix config command to get the current value of parameter sender_bcc_maps:" When I try to create a new virtual server I get the same error message. Where do I need to start to fix this?

First, when you say you setup a server for someone to host websites…are you saying you installed virtualmin on a system for them, or you are running virtualmin and you added a new virtual server for them?

Dont confuse a virtual server with a vps…they are not the same thing.

A virtual server is just an apache “virtual host” (mainly for 1 primary domain / website).

An apache virtual host is capable of running more but its not for hosting professionally hundreds of domains…thats a vps or dedicated system…hence webmin/virtualmin installation with hundreds of virtual servers/domains. (In Cpanel apache virtual hosts and virtualmin virtual servers, are called domains.)

I habe never put a docker inside an apache virtual host before. That i would have thought would go with its O/S onto a vps or dedicated system directly.

So which of te above is it that you have done…a new webmin/virtualmin install on a vps, or a virtualmin virtual server?

I assume you are trying to do something a bit like this…

Not a Virtualmin problem. Since it mentioned postfix I decided to check on the status of postfix and it wasn’t running. Tried to start and it failed. Checking with systemctl shows issues with the config file. Everything was working OK until I rebooted the server. First thing I noticed was mariadb not running. Mariadb wouldn’t start, checking my.cnf showed the config file had been changed. The same with postfix config. Evidently the python based programme I installed really screwed things up. I tried to follow some instructions that were written by someone that did not speak English as a first language. I may rebuild the server as I am now thinking I will just have issues down the road. I contacted the developer about clearer instructions for CentOS but since then I have decided to go a different route.

@ [adamjedgar] To answer your question, I am using the terminology that Virtualmin uses. If you look at the interface, you will see, “virtual server summary”, “create virtual server”, and so forth.

I do appreciate the offer of help. This was not a Virtualmin problem but screwed up config files by a script that did not fully explain what it would do and I don’t understand python that well.

A virtualmin virtual server is not a vps…thats what i am trying to tell you.
The reason your 3rd party program and docker screwed everything up is because you are going about this with the wrong idea in mind.
A virtualmin virtual server is exactly the same as an apache virtual host. Cpanel call a virtual host a domain. A domain is where a html website resides.

A docker is normally a container that contains apache…not usually the other way around. It seemed to me thst you are trying to run webmin/virtualmin on a system alongside a docker container.

I can only imagine that is why virtualmin got all screwed up. Control panels normally dont like their install being messed around with by a 3rd party application…that is just asking for trouble.
I am not experienced with docker containers. I am not sure how you run them inside virtualmin.

Normally i would have thought that virtualmin runs inside the docker container. The idea being that the docker allows for very fast deployment of identical virtual environments…or clones.

1 Like