https working but http doesn't

I am new to virtualmin and am learning the ropes.

I have setup my server, setup virtualmin, created a virtual server and I am serving a wordpress site from it.

My problem is that https://brianhoskins.uk works fine, but http://brianhoskins.uk doesn’t.

I have looked through the virtualmin settings and cannot find anything that would explain this. Any ideas will be much appreciated.

Regards,

Brian

Howdy,

Hmm, when looking at what ports are listening for connections, I’m not able to connect to port 80.

Is there perhaps a firewall that’s blocking the connections?

Or, if the server is behind a NAT router, is port 80 being forwarded into your server?

Lastly – is your server perhaps being hosted on a residential Internet connection? If so, it’s possible that your provider is blocking some ports.

-Eric

Thank you very much indeed for taking the time to reply Eric.

You were absolutely right, port 80 was not forwarded to my server in the router settings! How embarrassing! In my defense, I had previously set this up but perhaps a firmware update over-wrote it.

I checked the terms and conditions with my internet provider and apparently serving content is forbidden. So maybe that’s why they cleared the rule on a firmware update. They’re not blocking it though, because I reset the rule and now it’s working.

I shall have to consider changing my account to a small business package.

Cheers,

Brian.

Great, I’m glad to hear that’s working now!

If you’re considering getting a business class line – I might toss out the suggestion that there are super cheap, quality VPS’s out there.

One such example that I use on personal servers is Linode… you can get a low-end Linode for $5/month. If you bump up to $10, you’re getting 2GB of RAM and 50GB of disk space.

There’s plenty of other similar services out there by other quality vendors, that’s just an example.

Anyhow, glad to hear that’s all working now, good luck with whatever direction you opt to go with that!

-Eric