https:// redirect not working. Do i need to disable edit virtual server/enabled features/apache website?

i have struck upon a problem…

  1. used virtualmin to obtain and install a Letsecvrypt SSL certificate

  2. then went to virtualmin/system settings/virtualmin configuration/SSL settings and selected “redirect http to https by default”

  3. browsing website and its still loading http

Do i need to manualy disable virtualmin/edit virtual server/enabled features/apache website (thus only enabling apache ssl website?)

If the above is true, why isnt virtualmin automatically turning off the http website when i install SSL? (surely it should either do this or provide a pop up window asking if that is what i would like done?)

You just have to clear your redirection and then just get the SSL for your domain.
Then after redo your site redirection.
It is that easy.