https - how to make it trusted?

Hi, this is no big deal, but kindda annoying… Always when I access my webmin via browser, it needs to be with https, but my browser says its certificate is not trusted…

How can I change it?


That message will occur when using a self-signed SSL certificate, or a commercial SSL cert that isn’t fully setup.

What kind of SSL certificate are you using there?


None, I guess… I just installed virtualmin…


It sounds like you may need a commercial SSL certificate. That’s what is needed in order to prevent the warning message that otherwise pops up when accessing a self-signed SSL certificate.

What many people do is pick a particular domain to obtain a commercial SSL certificate for, and then go into Virtualmin -> Edit Virtual Server -> Enabled Features, and enable the SSL feature for that domain.

From there, you can go into Server Configuration -> Manage SSL Certificates, and you can generate the CSR necessary to obtain a commercial SSL certificate.

Once you have it installed, you can then click the “Copy to Webmin” and other buttons there to copy the SSL certificate to the other services running on your server.


StartSSL is a good certificate service to get started. They’re comparatively very cheap.

Thank you all ^^