httpd-devel on CenOS 6.5 fail

Hi!
Could you help me to resolve this issue?

httpd-devel on CenOS 6.5 fail

Error: Package: httpd-devel-2.2.15-29.el6.centos.x86_64 (base)
Requires: httpd = 2.2.15-29.el6.centos
Installed: 1:httpd-2.2.15-28.el6.vm.2.x86_64 (@virtualmin)
httpd = 1:2.2.15-28.el6.vm.2
Available: httpd-2.2.15-29.el6.centos.x86_64 (base)
httpd = 2.2.15-29.el6.centos
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
… install failed!

Thank you,

Installing package(s) with command yum -y install httpd-devel …

Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile

  • base: mirror.umd.edu
  • extras: centos.mirror.nac.net
  • updates: centos.mirror.nac.net
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package httpd-devel.x86_64 0:2.2.15-29.el6.centos will be installed
    –> Processing Dependency: httpd = 2.2.15-29.el6.centos for package: httpd-devel-2.2.15-29.el6.centos.x86_64
    –> Processing Dependency: apr-util-devel for package: httpd-devel-2.2.15-29.el6.centos.x86_64
    –> Running transaction check
    —> Package apr-util-devel.x86_64 0:1.3.9-3.el6_0.1 will be installed
    –> Processing Dependency: openldap-devel for package: apr-util-devel-1.3.9-3.el6_0.1.x86_64
    –> Processing Dependency: expat-devel for package: apr-util-devel-1.3.9-3.el6_0.1.x86_64
    —> Package httpd-devel.x86_64 0:2.2.15-29.el6.centos will be installed
    –> Processing Dependency: httpd = 2.2.15-29.el6.centos for package: httpd-devel-2.2.15-29.el6.centos.x86_64
    –> Running transaction check
    —> Package expat-devel.x86_64 0:2.0.1-11.el6_2 will be installed
    —> Package httpd-devel.x86_64 0:2.2.15-29.el6.centos will be installed
    –> Processing Dependency: httpd = 2.2.15-29.el6.centos for package: httpd-devel-2.2.15-29.el6.centos.x86_64
    —> Package openldap-devel.x86_64 0:2.4.23-34.el6_5.1 will be installed
    –> Processing Dependency: cyrus-sasl-devel >= 2.1 for package: openldap-devel-2.4.23-34.el6_5.1.x86_64
    –> Running transaction check
    —> Package cyrus-sasl-devel.x86_64 0:2.1.23-13.el6_3.1 will be installed
    —> Package httpd-devel.x86_64 0:2.2.15-29.el6.centos will be installed
    –> Processing Dependency: httpd = 2.2.15-29.el6.centos for package: httpd-devel-2.2.15-29.el6.centos.x86_64
    –> Finished Dependency Resolution
    Error: Package: httpd-devel-2.2.15-29.el6.centos.x86_64 (base)
    Requires: httpd = 2.2.15-29.el6.centos
    Installed: 1:httpd-2.2.15-28.el6.vm.2.x86_64 (@virtualmin)
    httpd = 1:2.2.15-28.el6.vm.2
    Available: httpd-2.2.15-29.el6.centos.x86_64 (base)
    httpd = 2.2.15-29.el6.centos
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    … install failed!

Howdy,

Hmm, it looks like you have a slightly older Apache version installed there – and as your system attempts to pull in the Apache devel package, that issue is causing it to pull it from the CentOS repo, rather than the Virtualmin repo.

You could either try updating Apache to the latest version, which you should be able to do by running a “yum update” – or you could manually download the devel package from the Virtualmin software repo, and install it using the rpm command. You can find it here:

http://software.virtualmin.com/gpl/centos/6/x86_64/httpd-devel-2.2.15-28.el6.vm.2.x86_64.rpm

Hi Andreychek,

Thank you for your quick answer.
My server didn’t have the Virtualmin repo in place.

After installing with
rpm -ivh http://software.virtualmin.com/gpl/centos/6/x86_64/virtualmin-release-latest.noarch.rpm

Then yum update
yum install httpd-devel
work perfect.