httpd-devel install fails

What should I do to resolve this?

# yum install httpd-devel

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Setting up Install Process
Resolving Dependencies

–> Running transaction check
—> Package httpd-devel.x86_64 0:2.2.15-15.el6.centos will be installed
–> Processing Dependency: httpd = 2.2.15-15.el6.centos for package: httpd-devel-2.2.15-15.el6.centos.x86_64
–> Finished Dependency Resolution
Error: Package: httpd-devel-2.2.15-15.el6.centos.x86_64 (base)
Requires: httpd = 2.2.15-15.el6.centos
Installed: 1:httpd-2.2.15-9.el6.2.vm.x86_64 (@virtualmin)
httpd = 1:2.2.15-9.el6.2.vm
Available: httpd-2.2.15-15.el6.centos.x86_64 (base)
httpd = 2.2.15-15.el6.centos
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

You have to install httpd-devel from virtualmin’s repo. Did you disable it?

No. It doesn’t exist in /etc/yum.repos.d

Should be there, or how did you install virtualmin?

I used the script: ./install.sh

I did subsequently upgrade from CentOS 6.1 to 6.2. Maybe that deleted it, for some odd reason. Is there an rpm or something to install the repo file?

that’s probably the reason. in any case just look in the “manual installation” virtualmin docs :slight_smile: