Howto set up 2FA for usermin and virtualmin users

🛈 SYSTEM INFORMATION
OS type and version Debian 10
Virtualmin version 6.17-3

Please provide some documentation how to setup this feature
Thank you.

1 Like

At first, you would need to make sure that libauthen-oath-perl package is installed, if not install it with the following command:

apt-get install libauthen-oath-perl -y

Instructions for Webmin/Virtualmin:
Go to Webmin ⇾ Webmin Configuration: Two-Factor Authentication and enable two-factor authentication and hit save button.
When this done, master administrator can configure two-factor authentication in Webmin ⇾ Webmin Users module. Virtualmin virtual server owners, will be able to do it by themselves after logging in from Administration Options ⇾ Enroll For Two-Factor: Two-Factor Authentication page.

Instructions for Usermin:
For Usermin the steps are exactly the same with the only difference that it should first be enabled on Webmin ⇾ Usermin Configuration: Two-Factor Authentication page.

2 Likes

As per your advice I manage to configure 2FA configuration for master administrator: 2FA is working for both: virtualmin and usermin access.
Also managed to configure it for virtualmin virtual server owners, i.e. virtualmin and usermin access with 2FA is working.
Unfortunately I was not able to to configure 2FA for those usermin email users. Could you please give a hint how can I enroll a simple usermin email user to have 2FA working.
Thank you.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Well, you would need at first enable 2FA in Webmin / Usermin Configuration, e.g.:

… and then make this module available to the Usermin users, e.g.:

1 Like

@Jamie, what do you think of making 2FA available by default for all users who installed Virtualmin using install script? I’m afraid people won’t be able to find these options.

Sure, I’d support enabling this by default for new Virtualmin users.

@Jamie, alright! Implemented. Does it look good to you?

2 Likes

Looks good to me!

Cool, thanks!