How To Set Up SPF Records In Virtualmin?


MX tests show that my server is not using SPF records.

Is there an easy way to enable Virtualmin to use the records? (what I know about spf records couldn’t fill a thimble, but I’ve been having some issues with emails being rejected and the lack of spf was pointed to as a possible factor).

Thanks ahead of time for any help that can be provided,


You can add SPF records in virtualmin here:
Server Configuration -> DNS options



Thanks for replying Guido, but I don’t have a DNS Options under Server Configuration, is that just in pro perhaps?

That should be in both Pro and GPL… do you have “Edit DNS Records” in there?

And are you doing that as a Virtual Server owner, or as root? You may want to try it as root just to make sure it’s not a permissions problem.


No, attached image of where I am looking. I am signed on as root when I took this image -


(3.93.gpl GPL on CentOS Linux 6.3)
(I see I am behind on updates, will update this evening)

Yeah, the option was called something different back then… it was probably available in “Services”, though I forget :slight_smile:

If you upgrade to the most recent version, you should see “DNS Options” though.


My SPF records are all working and valid…

When a spammer spoofs one of my domains and the recipient is invalid and bounces it back to me, is there a way to stop the bounced emails coming to me? I am tired of seeing them.

I would recommend you start your own thread on that issue. That way more people are likely to see it. I cannot help you however, sorry.