How to prevent error 503 in browser when webmin update is performed?

Hi guys,
ran the Webmin/usermin update this morning. All went ok, however, I was also working on a Wordpress website at the time the update was running and it threw an error 503 “site down due to maintenance capacity problems”

Apart from running updates outside of peak times, how can i tweak Virtualmin so the update process does not use up all available resources temporarily?

see the update process below
The following packages will be upgraded:
usermin webmin
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.7 MB of archives.
After this operation, 41.0 kB of additional disk space will be used.
Get:1 http://software.virtualmin.com/vm/6/apt virtualmin-universal/main amd64 usermin all 1.780 [8829 kB]
Get:2 http://software.virtualmin.com/vm/6/apt virtualmin-universal/main amd64 webmin all 1.930 [16.9 MB]
apt-listchanges: Reading changelogs…
Fetched 25.7 MB in 4s (6172 kB/s)
(Reading database …
(Reading database … 5%
(Reading database … 10%
(Reading database … 15%
(Reading database … 20%
(Reading database … 25%
(Reading database … 30%
(Reading database … 35%
(Reading database … 40%
(Reading database … 45%
(Reading database … 50%
(Reading database … 55%
(Reading database … 60%
(Reading database … 65%
(Reading database … 70%
(Reading database … 75%
(Reading database … 80%
(Reading database … 85%
(Reading database … 90%
(Reading database … 95%
(Reading database … 100%
(Reading database … 125329 files and directories currently installed.)
Preparing to unpack …/archives/usermin_1.780_all.deb …
Unpacking usermin (1.780) over (1.771) …
Preparing to unpack …/archives/webmin_1.930_all.deb …
Unpacking webmin (1.930) over (1.921) …
Setting up webmin (1.930) …
Webmin install complete.

Processing triggers for systemd (232-25+deb9u11) …
Setting up usermin (1.780) …
Usermin install complete.