How to php management

SYSTEM INFORMATION
**OS type and version: Ubuntu 20.04
**Webmin version: 1.981
**Virtualmin version: 6.17.3
**Related products version: Versione Usermin 1.823

Hi all,
my question are:

i installed all php versions from 7.0 to 8.1 in the same way. In the end I can only use 7.4 and 8.0 for my domains for both fpm and cgi. how to make them all available?

Hi,

If you go to virtual-server.local - Server Configuration ⇾ PHP Options do you see those versions available for selection?

In addition, please double check that you have all needed packages installed using this guide.