How to enable virtio on existing KVM virtual machine?

So this machine is using LVM as the filesystem, but, apparently, the default is not virtio as in cloudmin under Edit System -> Advanced KVM settings, it says the KVM disk driver is IDE. So, I suppose I should enable that in cloudmin settings as the default.

But for existing machines, can this be changed via Cloudmin? If so, how?


I asked Jamie about this – he says it’s unfortunately not possible to change that setting for existing VM’s.

The problem is that it would cause a lot of devices and file paths to change, which would in turn cause the system to not boot.

It sounds like the only workaround would be to provision a new VM, and then to migrate your existing VM over to the new one.


Actually, I was able to make it work by changing only a couple of things… One was the /etc/webmin/servers/*.serv file to say virtio instead of IDE.

Second, was to change /etc/fstab on the virtual machine to use vdb1 instead of sdb1.

Third was to change /boot/grub/grub.conf to use vdb1.

That’s all it took. So, it would be possible to change Cloudmin I would think to do the same.