How to Enable Quotas?


One of my machines does not appear to have quotas enabled.

How would I enable quotas in the manner typical of Virtualmin’s default configuration.


Webmin->System->Disk and Network Filesystems

Click on the filesystem that contains /home (could be /home, could be / (root filesystem)).

Set "Use Quotas?" to User and Group.

Save it.

Webmin->System->Disk Quotas

Enable quotas on the previously configured filesystem.

Reboot or remount filesystem (if it’s the / system you’ll probably need to reboot…also if you use something other than Linux, since only Linux seems to be able to remount active filesystems to enable quotas, as far as I know).

On Linux the following usually works:

mount -o remount /

If it fails, you’ll have to reboot.

Thanks. That did it.