How to disable spamassassin completely

Hi, I’m using Webmin/Virtualmin.

I have a problem about spamassassin filter.

First question: How to disable Spamassassin completely?
When I uncheck both “Spam Filter enabled?” and “Virus Filter enabled?”,
mails are no longer delivered to the spam folder, but Spamassassin is still used,
Is it impossible as long as I’m using Virtualmin?

I have customers who are using POP, and they say complain that they cannot receive mail judged as a spam, so I have to give up using it.

Second question: Is Spamassassin filter also used when mail is sent?
Some users report that “[SPAM]” prefix is automatically added in mails they sent even they are new.

Thank you.

Howdy,

SpamAssassin shouldn’t be used when the feature is unchecked. What signs are you seeing that show that it’s being used?

Also, SpamAssassin is not used for outgoing email, only incoming email.

-Eric

Lets try to address your problems rather then just disabling it. I have had similar issues with POP3 users not getting their SPAM mail.

The default delivery settings are to put spam mail in the spam folder, which POP users can’t access.

Go to “System Settings” -> “Virtualmin Configuration” -> “Spam filtering options”

Change “Default delivery for spam” to “Deliver normally” and click save.

This can be overridden on a per domain & user basis.

Also, what OS are you running. What SMTP server are you running? (Postfix/Sendmail/etc)