How to change Let's Encrypt to ACME Version 2 ... needed for cert renewal. (short term workaround.)

As a short term fix for Let’s Encrypt until Virtualmin has full support. This workaround was a tad hidden in a long message chain on the Webmin forum, thought getting it into the open might help a few people.

Solved with:

Centos / Red Hat based : " yum install socat certbot "

Debian / Ubuntu based: " apt-get install socat certbot "

System Prompt ># " certbot register "

Complete with a valid e-mail.

Try to request new Let’s Encrypt

I followed these simple steps on Centos 7 - worked perfectly.

Oh man couldn’t you have posted this a day ago? I was troubling with this for a couple of days until I came up with this solution just yesterday. If you just install AND register certbot webmin will go with it without any further editing. Confirmed working. :slight_smile:
I was actually hoping that none would have written about it and I could make my first humble contribution but there you go.