How do you get your email?

I set up an email account and in Outlook I put admin.website.com for the user name and entered the password. I then clicked off my outgoing server requires authentication, but it won’t pick up any email.

Did I set this right? This has to be the most confusing control panel I’ve tested to date.

You can see exactly what username you would use by looking at the Edit Mail/FTP Users page for the virtual server in question.

You’ll want to make sure you actually have mail to pick up, check the maillog while attempting to pick it up, and send along the exact error messages you get from either your client or the maillog.

Didn’t check the logs? Didn’t include any error messages? Your request for help has got to be the most confusing request for help I’ve read all day. (“It doesn’t work” is never a good description of the problem.) :wink:

OK, I sent my self mail today and yesterday. It didn’t come back, so must be delivered. I have outlook set up as mail.myweb.com for both incoming and outgoing. I have username set up as admin.confirming-email.com and I have my password entered correctly. I clicked off requires authentication for sending. I don’t get any errors coming back in outlook, just the send recieve box keeps popping up like it has a wrong user name or password. Here is the last part of the mail log after sending my self email.

Sep 17 07:00:21 ns1 dovecot: pop3-login: Disconnected: rip=207.47.130.132, lip=192.168.0.100
Sep 17 07:04:21 ns1 postfix/smtpd[16864]: connect from misav03.sasknet.sk.ca[142.165.20.164]
Sep 17 07:04:21 ns1 postfix/smtpd[16864]: 4A3A7E083D6: client=misav03.sasknet.sk.ca[142.165.20.164]
Sep 17 07:04:21 ns1 postfix/cleanup[16868]: 4A3A7E083D6: message-id=<008601c7f92b$0708b6b0$151a2410$@net>
Sep 17 07:04:21 ns1 postfix/qmgr[2931]: 4A3A7E083D6: from=<mwmurphy@sasktel.net>, size=2963, nrcpt=1 (queue active)
Sep 17 07:04:21 ns1 postfix/smtpd[16864]: disconnect from misav03.sasknet.sk.ca[142.165.20.164]
Sep 17 07:04:21 ns1 postfix/local[16870]: 4A3A7E083D6: to=<admin.confirming-email@ns1.confirming-email.com>, orig_to=<admin@confirming-email.com>, relay=local, delay=0.21, delays=0.12/0.01/0/0.08, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME)
Sep 17 07:04:21 ns1 postfix/qmgr[2931]: 4A3A7E083D6: removed
Sep 17 07:06:22 ns1 dovecot: pop3-login: Disconnected: rip=207.47.130.132, lip=192.168.0.100
Sep 17 07:06:33 ns1 last message repeated 3 times

So, did you check the mail/ftp users page to be sure you are using the right username?

This might also be the debian dovecot being stupid. I might not have actually gotten the disable_plaintext_auth fix working on Debian. Check /etc/dovecot.conf for this option. If it’s not set to no, you’ll need to change it (if it’s commented out, you’ll need to remove the # mark to uncomment it). And then restart dovecot. (Plain is the only kind of login that’ll work against the shadow password database. If you’re concerned about security, use IMAPS/POP3S for connections, which provides full session encryption rather than just hashed passwords.)

That was it. I uncommented the line and changed yes to no and Voila, lots of spam email came in. :slight_smile:

Thanks for that.

Mike

Joe - What if there is not dovecot.conf in the /etc/ folder. I can’t find the dovecot.conf file anywhere.

Ooops - a little premature. I found it at /etc/dovecot/dovecot.conf

Several lines down in the file i found:

"# disable_plaintext_auth = yes"

Changed to:

"disable_plaintext_auth = no"

In Shell Konsole, typed:

"/etc/init.d/dovecot restart" <enter>

Dovecot restarts and "VIOLA" Outlook works now.