How do I get SMTP authentication going

I would like to get smtp authentication but how do I do that.

I have an email for instance set up at

I can’t when I send an email to this from another computer on the network using with smtp auth. turned on in thunderbird, I just get it continuously prompting me for a password. I am using the name “info.mydomain” as the username although in virtualmin it says this is the IMAP/FTP what username format should i use for pop3/smtp.

I am able to send mail easily though if i dont use smtp auth in thunderbird. That means smtp auth is not require on the virtualmin setup by default. How can I turn it on?

I am attaching a pic of the postfix smtp auth screen. see below…

if you notice "Reject Anonymous logoins" is on which would suggest that smtp is on? but i am still able to send without username and password? Unless the next item "Allow connections from same network" overides that. Does it?

What does allow connections from this system mean? is that for php scripts? Its unchecked…does that means php scripts like phpmailer using smtp cannot send mail?

Thats it for now. :slight_smile:

You may need to enable SMTPS and/or Submission in Postfix – an example of doing that is here:

I don’t seem to have a sasl group.

Should that have been created automatically by virtualmin?

There’s no posfix user in my ubuntu user/group manager now that i look. Just how do we do this adding of a postfix user to a slas group.

I think the issue with the sasl group was specific to the Ubuntu problem that person was having.

If you’re using CentOS, I think all you’ll need to do is uncomment those lines from the file, and restart postfix.

If that doesn’t work, just yell – and show any errors that you see in /var/log/maillog.

Okay, I do see you’re using Ubuntu – but just get the SMTPS/Submission stuff enabled for now, we’ll deal with the permissions issues later… those may all be corrected by now.

Ok i’ve seen how to do the postfix/sasl thing…

sudo usermod -G sasl postfix

But one problem…i can still send mail without smtp authentication in thunderbird for isntance…it should give me an error if I dont auhtenticate shouldnt it?

oh and i have turned on the smtps and submission as well thru the vm interface.

If it’s not working, you should receive an error. If it’s hitting your server, there should be an error in the log file.

What does it show in /var/log/mail.log when you attempt to authenticate?

No, i’m not having the permisson error any more since turning on submissions and smtps. I can now send mail with authentication.

My problem now is i am still able to send without authentication also. Is there a way to stop that?

For instance i cannot send email to an isp unless i provide my username and password to the smtp server, otherwise it would deny me.

I would like to do the same in my setup.


It shouldn’t require you to authenticate if you’re sending emails to users on that server.

It should only require a username and password if you’re sending emails to servers outside of your own (ie, relaying).

ohhhh i see…
one thing though…

I just took a look at /etc/default/saslauthd

and in the top it has …

Should saslauthd run automatically on startup? (default: no)


cant that be correct?


Well, that could be a problem – but only if there isn’t another “START=yes” at the bottom of the file.

I hadn’t noticed this before, but that file on my system as “START=no” at the top and “START=yes” at the bottom.

Does saslauthd start up for you? Are you seeing that if you type this:

ps auxw | grep saslauthd

mumble nevermind it has start=yes at the very bottom of the file also.