How do I access to webmails, unable to log in

Hello, I have installed Virtualmin recently. Yesterday I added a domain and I can create mail alias with newly added domain. But unfortunately I can’t login to webmail as I have installed roundcube script. My server is running on centos 6. How do I access to my webmail?

Can you elaborate “can’t login to webmail”? What exactly are you trying and what happens when you try?

Sure. When I try log in to roundcube in with and my account password it’s showing login failed.


If you log into Virtualmin, and click Edit Users, you’ll see the actual username under the “IMAP / POP3 / FTP login” field.

Is that the username that you’re using to log in?


@andreychek yes and I created new email alias, but still unable to access those. While tring to login to webmail getting an error “login failed”.


Hmm, do you see any error messages in /var/log/maillog while attempting to login via RoundCube?


Hello, sorry for my late reply as my last two comments were held for moderation. I tried to login once again and here’s those error I got from maillog

Dec 24 02:07:52 server imap[13758]: accepted connection
Dec 24 02:07:52 server imap[13758]: badlogin: localhost [::1] DIGEST-MD5 [SASL(-13): user not found: no secret in database]
Dec 24 02:07:52 server master imap[1786]: about to exec /usr/lib/cyrus-imapd/imapd
Dec 24 02:07:52 server imap[1786]: executed

Are you sure you’re using the correct username? The error log would indicate that the username you tried could not be found.


Hmm, it also appears that you’re using Cyrus for IMAP authentication – that’s not what’s installed by default when Virtualmin is put onto the system… it’s possible that Cyrus isn’t configured properly for handling logins.

Is there a reason you wanted to use that over Dovecot?


@Locutus Yes I’m sure. I’ve double checked username and password.

@andreychek I’ve been using dovecot before, but this time when I installed dovecot smpt wasn’t working. With cyrus I am able to send or receive mails if I add a user(not by creating email alias from Vmin) from SSH(with adduser command). If cyrus is not config’ed correctly how do I supposed to do that?

I’m unfortunately not familiar with setting up Cyrus – but I suspect your issue is either that you’re using the wrong login name, or that Cyrus is configured to authenticate via a means other than using system users.

My suggestion would be to use Dovecot, though in theory Cyrus should be able to work properly, if configured correctly. But I’m unfortunately not able to offer input on how to configure Cyrus.


Okay, I’m doing it now.

Hello, it’s working fine now after I reinstalled the package. Now my system is freshly installed and running properly. But one thing I noticed if I try to install phpMyAdmin and want to access that at as mentioned in installation page, just got error that the navigation.php is missing. Does Vmin auto-installation comes with phpmyadmin?

Merry Christmas :slight_smile:

There’s a script installer for phpmyadmin that should be available in the GPL version too.

Did you install phpmyadmin from a Linux package? The suggested way is to create a Virtualmin virtual server and install it there using either the script installer, or download phpmyadmin from its website.

@Locutus I installed Vmin as documentation suggested. I knew that there is a script of phpmyadmin comes with the package. Tried to install them from script installer, but after installation when I try to acces to it, says navigation.php is not found. I have checked that mysqld is running properly. One more thing httpd is running at 5.1 and named service at 6.1, is it normal?

Merry Christmas----

Okay I’m sorry, can’t say much more there. I don’t have much experience with phpmyadmin really; I merely installed it for testing purposes a few times (without problems) quite a while ago. I suggest checking Apache’s error logs and googling for any error messages you get. I suppose if it’s a known issue, that should give you some way of fixing it.

Hmm, I’m not entirely certain what would cause the issue you’re seeing there.

Do you see the same issue if you try installing phpMyAdmin into a different domain, using the Virtualmin Install Script?

Also, what distribution/version are you using?


@andreychek Yes I’m getting the same problem saying navigation.php not found. I tried old( and latest(4.1.1) both and got the same problem after installing using Vmin install script option.

@Locutus I have been searching solution by googling for this issue, but didn’t find any helpful resources.

What distro/version are you using?