How can I pretend the zone-settings for BIND?

Hi,

everytime creating a new Domain with Virtualmin, a new zone is used in /etc/bind/named.conf.local.
Thats fine, but by creating the zone-files, Virtualmin creates the parameter “allow-transfer{…}”, too and fills it with some IPs.
Because of my global settings I don’t need this, but I don’t now how to change or delete it.

I’ve tried changing the BIND-Settings in the default-server-profile and something near it. But that didn’t solved it.

Can anybody help me?
Thanks!

Has anybody an idea?

this can be changed in the server templates
Virtualmin - System Settings - Server Templates - Default Template (or the one you use)
In the dropdown choose BIND DNS Domain - Automatically add named.conf directives

If that is grayed out then first set Additional named.conf directives for new zones to Directives below

I’ve found it. It’s a little bit stupid, I’ve tried a lot of settings in this section, but couldn’t solve the problem. Now it’s all right, I can’t say why…
Thank you very much!