hotmail not receiving emails

HI
When we try to send emails to Hotmail address they are not being received.
If we try to send to yahoo or gmail they work fine

Any ideas on why

We have DKIM and SenderID setup and are not on any spam block lists.

I have outlook looking at this as well

log files of the last couple of emails

Logs

Mar 17 09:58:35 server postfix/pickup[24152]: 4DA2516000B: uid=1000 from= Mar 17 09:58:35 server postfix/cleanup[25215]: 4DA2516000B: message-id=20150317135835.4DA2516000B@server.stayrove.com
Mar 17 09:58:35 server postfix/qmgr[2155]: 4DA2516000B: from=stayrove@server.stayrove.com, size=490, nrcpt=1 (queue active) Mar 17 09:58:37 server postfix/smtp[25217]: 4DA2516000B: to=stevenbegley@hotmail.com, relay=mx3.hotmail.com[65.55.92.184]:25, delay=2, delays=0.01/0/0.65/1.3, dsn=2.0.0, status=sent (250 20150317135835.4DA2516000B@server.stayrove.com Queued mail for delivery) Mar 17 09:58:37 server postfix/qmgr[2155]: 4DA2516000B: removed Mar 17 09:59:15 server postfix/pickup[24152]: C08A416000B: uid=1000 from= Mar 17 09:59:15 server postfix/cleanup[25215]: C08A416000B: message-id=20150317135915.C08A416000B@server.stayrove.com
Mar 17 09:59:15 server postfix/qmgr[2155]: C08A416000B: from=stayrove@server.stayrove.com, size=490, nrcpt=1 (queue active) Mar 17 09:59:17 server postfix/smtp[25217]: C08A416000B: to=stevenbegley@hotmail.com, relay=mx1.hotmail.com[65.54.188.72]:25, delay=1.4, delays=0.01/0/0.57/0.82, dsn=2.0.0, status=sent (250 20150317135915.C08A416000B@server.stayrove.com Queued mail for delivery) Mar 17 09:59:17 server postfix/qmgr[2155]: C08A416000B: removed Mar 17 09:59:55 server postfix/pickup[24152]: C4DB716000B: uid=1000 from= Mar 17 09:59:55 server postfix/cleanup[25215]: C4DB716000B: message-id=20150317135955.C4DB716000B@server.stayrove.com
Mar 17 09:59:55 server postfix/qmgr[2155]: C4DB716000B: from=stayrove@server.stayrove.com, size=490, nrcpt=1 (queue active) Mar 17 09:59:58 server postfix/smtp[25217]: C4DB716000B: to=stevenbegley73@gmail.com, relay=gmail-smtp-in.l.google.com[74.125.68.27]:25, delay=2.3, delays=0.01/0/1.1/1.2, dsn=2.0.0, status=sent (250 2.0.0 OK 1426600798 k14si14847517ico.96 - gsmtp) Mar 17 09:59:58 server postfix/qmgr[2155]: C4DB716000B: removed Mar 17 10:00:49 server postfix/pickup[24152]: 02CC016000B: uid=1000 from= Mar 17 10:00:49 server postfix/cleanup[25215]: 02CC016000B: message-id=20150317140049.02CC016000B@server.stayrove.com
Mar 17 10:00:49 server postfix/qmgr[2155]: 02CC016000B: from=stayrove@server.stayrove.com, size=490, nrcpt=1 (queue active) Mar 17 10:00:51 server postfix/smtp[25217]: 02CC016000B: to=stevenbegley73@gmail.com, relay=gmail-smtp-in.l.google.com[74.125.68.27]:25, delay=2.2, delays=0.01/0/1.1/1.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1426600851 h5si2099633igt.22 - gsmtp) Mar 17 10:00:51 server postfix/qmgr[2155]: 02CC016000B: removed

Howdy,

Hmm, the logs show that Hotmail accepted your emails – is it possible that they’re showing up in the spam folder for the account there?

-Eric

You could ask Hotmail if your domain or IP is on their blacklist. Another thing you could try is to set rDNS and check if you will get better result.