Hostname issues (I think)

I think I might have made a mistake setting the hostname when first installed virtualmin, and now I’m having issues logging in when I address the system by domain name, (everything works great if I address by IP.)

Prior to running the installer script, I set the hostname to, say, machine01
Of course, that’s not a fully-qualified name, which I now realize.

Login works if I go to https://[ip-address]:10000, but not if i go to

What all do I need to change to convince virtualmin that my fqdn is actually that? Changing in /etc/hosts changes the value reported by System hostname: on the “System Information” page, but doesn’t seem to have any impact on the login issue. I’ve tried restarting webmin after changing it as well. Running CentOS 5.3.

Any hints would be greatly appreciated, thanks!

if you have any domain running on that box, you can login to that too.

if the hostname isn’t set correctly, you can ssh into the box and type as root:
hostname machine01.yourdomain.tld

Yep, I tried that, still no dice. Now “hostname -f” returns:


and when I open https://machine01.yourdomain.tld:10000 in my browser, I see:

“You must enter a username and password to login to the Webmin server on machine01.yourdomain.tld.”

(note trailing . )

When I try and log in with admin username/password combination I can SSH in with, I get:

“Login failed. Please try again.”

But if I do the same thing with https://[IP address]:10000 I see:

“You must enter a username and password to login to the Webmin server on [IP address].”

and logging in works. :-\